Bug 1187745 - Regression caused by [bug 1044122] fix: modules cannot return values due to bug in Module::empty_response
Summary: Regression caused by [bug 1044122] fix: modules cannot return values due to b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci
Version: 6.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jan Pokorný [poki]
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1199561
TreeView+ depends on / blocked
 
Reported: 2015-01-30 19:06 UTC by Jan Pokorný [poki]
Modified: 2019-04-16 14:34 UTC (History)
4 users (show)

Fixed In Version: ricci-0.16.2-78.el6
Doc Type: Bug Fix
Doc Text:
Cause: Regression caused by a fix for bug 1044122. Consequence: Replies to requests, e.g., those initiated by luci, were missing the expected information, such as the status of selected daemons. As a result, luci or ccs could make false claims about the cluster, such as the daemon status, or about particular management tasks. Fix: Replies to clients' requests are composed correctly again. Result: Users will not get confused or misinformed when managing clusters.
Clone Of:
: 1199561 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:34:10 UTC


Attachments (Terms of Use)
Patch to fix the issue (5.77 KB, patch)
2015-03-05 14:39 UTC, Jan Pokorný [poki]
no flags Details | Diff
Helper file to test the bugfix (307 bytes, text/plain)
2015-03-05 16:26 UTC, Jan Pokorný [poki]
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1405 normal SHIPPED_LIVE ricci bug fix and enhancement update 2015-07-20 18:07:08 UTC
Red Hat Bugzilla 1187751 None None None Never
Red Hat Knowledge Base (Solution) 1337833 None None None Never

Internal Links: 1187751

Description Jan Pokorný [poki] 2015-01-30 19:06:25 UTC
It has been discovered that ricci modules built from ricci.srpm
(ricci-mod{service, rpm, log, storage, virt}) are not able to
return their output variables (in a sense of remote procedure call)
due to a bug in common/Module.cpp.

This results, for instance, in inability to examine status of clustering
daemon (running/stopped).

Note that core manipulations with cluster(s) are not affected as
modcluster (ricci module dedicated to core cluster.conf handling)
is built from clustermon.srpm that hasn't been patched in this way
([bug 1044122]) is irrelevant there.

Comment 3 Jan Pokorný [poki] 2015-03-05 14:39:47 UTC
Created attachment 998392 [details]
Patch to fix the issue

Comment 5 Jan Pokorný [poki] 2015-03-05 16:26:39 UTC
Created attachment 998457 [details]
Helper file to test the bugfix

# /usr/libexec/ricci-modservice <test-bz1187745


BEFORE:

<?xml version="1.0"?>
<response API_version="1.0" sequence="">
	<function_response function_name="query"/>
</response>


AFTER (example):

<?xml version="1.0"?>
<response API_version="1.0" sequence="">
	<function_response function_name="query">
		<var mutable="false" name="result" type="list_xml">
			<service description="" enabled="false" name="ricci" running="false"/>
			<service description="" enabled="false" name="modclusterd" running="false"/>
			<service description="" enabled="false" name="cman" running="false"/>
			<service description="" enabled="false" name="rgmanager" running="false"/>
		</var>
		<var mutable="false" name="success" type="boolean" value="true"/>
	</function_response>
</response>


Please re-test [bug 1044122] as well -- it is important that no temporary
batch in queue is not crippled in a way similar to BEFORE vs. AFTER
(i.e., no subtree is suddently missing).

Comment 13 errata-xmlrpc 2015-07-22 07:34:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1405.html


Note You need to log in before you can comment on or make changes to this bug.