Bug 1187882 - The most recent systemd upgrade causes Juno nova-docker containers failure to launch on Fedora 21
Summary: The most recent systemd upgrade causes Juno nova-docker containers failure to...
Status: CLOSED DUPLICATE of bug 1188037
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-31 11:28 UTC by Boris Derzhavets
Modified: 2015-02-05 20:23 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-02-05 20:23:57 UTC


Attachments (Terms of Use)

Description Boris Derzhavets 2015-01-31 11:28:00 UTC
Description of problem:

Nova-docker driver installed on RDO Juno AIO Node fails to launch Nova-Docker
container. /var/log/nova/nova-compute.log 

APIError: 500 Server Error: Internal Server Error ("Cannot start container 1d2ff4e5626d6ffaeae6690610868bfe8b299a758c2b1c08c1d0a9dfd3c6e739: write /sys/fs/cgroup/memory/system.slice/docker-1d2ff4e5626d6ffaeae6690610868bfe8b299a758c2b1c08c1d0a9dfd3c6e739.scope/memory.memsw.limit_in_bytes: invalid argument")


Version-Release number of selected component (if applicable):
Fedora 21, Nova-Docker driver installed via stable/juno 
# git clone https://github.com/stackforge/nova-docker
# cd nova-docker
# git checkout stable/juno
# python setup.py install

How reproducible:

Steps to Reproduce:
1. `yum -y update`
2. Install RDO Juno (AIO) on F21 Workstation
3. Install Nova-Docker driver
# git clone https://github.com/stackforge/nova-docker
# cd nova-docker
# git checkout stable/juno
# python setup.py install
4.Update 
compute_driver=novadocker.virt.docker.DockerDriver'
in /etc/nova/nova.conf && service openstack-nova-compute restart
5.  
# docker pull rastasheep/ubuntu-sshd:14.04
# . keystonerc_admin
# docker save rastasheep/ubuntu-sshd:14.04 | glance image-create --is-public=True   --container-format=docker --disk-format=raw --name rastasheep/ubuntu-sshd:14.04
# . keystonerc_demo
# nova boot --image "rastasheep/ubuntu-sshd:14.04" --flavor m1.tiny --key-name  osxkey    --nic net-id=5fcd01ac-bc8e-450d-be67-f0c274edd041 ubuntuTrusty

Actual results:

Instance goes to ERROR state

Expected results:

Nova-Docker container loads && can be accessed via ssh root@floating-ip

Additional info:

Workaround 

`yum downgrade  systemd-python3 systemd-compat-libs systemd-libs systemd-python systemd libgudev1` installs

systemd-python-216-12.fc21.x86_64
systemd-compat-libs-216-12.fc21.x86_64
systemd-python3-216-12.fc21.x86_64
systemd-216-12.fc21.x86_64
rpm-plugin-systemd-inhibit-4.12.0.1-4.fc21.x86_64

and bring Nova-Docker Driver to working shape , actually fixes loading docker's
containers (1.3.2 ) on F21

Comment 1 Boris Derzhavets 2015-02-02 08:24:13 UTC
Another workaround upgrade systemd up to 218-3 :

# yum --enablerepo rawhide install systemd

or download systemd-218-3.fc22.src.rpm

# rpm -iv systemd-218-3.fc22.src.rpm
# cd rpmbuild/SPEC
# rpmbuild -bb systemd.spec
# cd ../RPMS/x*
# yum install libgudev1-218-3.fc21.x86_64.rpm \
libgudev1-devel-218-3.fc21.x86_64.rpm \
systemd-218-3.fc21.x86_64.rpm \
systemd-compat-libs-218-3.fc21.x86_64.rpm \
systemd-debuginfo-218-3.fc21.x86_64.rpm \
systemd-devel-218-3.fc21.x86_64.rpm \
systemd-journal-gateway-218-3.fc21.x86_64.rpm \
systemd-libs-218-3.fc21.x86_64.rpm \
systemd-python-218-3.fc21.x86_64.rpm \
systemd-python3-218-3.fc21.x86_64.rpm

Comment 2 Zbigniew Jędrzejewski-Szmek 2015-02-05 20:23:57 UTC

*** This bug has been marked as a duplicate of bug 1188037 ***


Note You need to log in before you can comment on or make changes to this bug.