Bug 11879 - Piranha web admin tool errors on lvs.cf
Piranha web admin tool errors on lvs.cf
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-02 22:38 EDT by dimambro
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-19 18:24:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dimambro 2000-06-02 22:38:37 EDT
First time execution of piranha web admin tool gave following message:

There was an error opening or creating the lvs.cf configuration file
The most likely cause is that the file permissions are incorrect.
They should be set as follows

-rw-rw-r--   1 piranha  nobody 0 Mar 1 12:00 /etc/lvs.cf
You can achieve this by issuing the following 3 commands as root
 touch /etc/lvs.cf
 chmod 664 /etc/lvs.cf
 chown piranha.nobody /etc/lvs.cf

I have set permissions and ownership as stated in the above message wil 
negative results.

I found workaround of setting owner to nobody and group to piranha. Now it 
works.
Comment 1 Phil Copeland 2000-07-18 14:32:55 EDT
Piranha was packaged to work out of the box on with a RH install
The default httpd.conf that the apache server installs is below

# User/Group: The name (or #number) of the user/group to run httpd as.
#  . On SCO (ODT 3) use "User nouser" and "Group nogroup".
#  . On HPUX you may not be able to use shared memory as nobody, and the
#    suggested workaround is to create a user www and use that user.
#  NOTE that some kernels refuse to setgid(Group) or semctl(IPC_SET)
#  when the value of (unsigned)Group is above 60000; 
#  don't use Group nobody on these systems!
#
User nobody
Group nobody


because every file access piranha makes is made with the User/Group access
rights of the web server itself, there is an assumption that it will be
nobody.nobody

The important thing here was to make sure that the web server would have file
permission rights to alter the lvs.cf file

that is why the permission mask was 664 (-rw-rw-r--) to allow the *group* write
access

Your assumption of changing the ownerships is mostly correct as the web server
you are running is likely running as user nobody, though your group may be set
as maybe -1 or -2 as opposed to the label nobody

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.