Bug 1187986 - unable to rename existing cluster
Summary: unable to rename existing cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Eli Mesika
QA Contact: Karolína Hajná
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-01 09:08 UTC by Pratik Pravin Bandarkar
Modified: 2019-10-10 09:39 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:55:53 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 37490 master MERGED core:unable to rename existing cluster/DC Never
Red Hat Knowledge Base (Solution) 1585513 None None None Never

Description Pratik Pravin Bandarkar 2015-02-01 09:08:27 UTC
Description of problem:
You cannot rename test_cluster -> test_CLUSTER. It fails with following error:
<snip>
Error while executing action: Cannot edit Cluster. Cluster name is already in use.
</snip>


Version-Release number of selected component (if applicable):
RHEV3.4

How reproducible:
100%

Steps to Reproduce:
1. create cluster with name "test_cluster
2. try renaming it to "test_CLUSTER"
3.

Actual results:
RHEV do not allow renaming the cluster from lower case to upper case.

Expected results:

It should allow to rename the cluster even if we are renaming from lower case to upper case. 

Additional info:

Comment 3 Karolína Hajná 2015-04-14 12:08:04 UTC
Verified on oVirt 3.6.0-1

Comment 6 errata-xmlrpc 2016-03-09 20:55:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.