Bug 1187999 - No network printing
Summary: No network printing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-01 11:17 UTC by antonio montagnani
Modified: 2015-02-08 21:56 UTC (History)
4 users (show)

Fixed In Version: firewalld-0.3.13-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-05 05:24:36 UTC


Attachments (Terms of Use)
debug file from local printer (31.09 KB, text/plain)
2015-02-01 11:22 UTC, antonio montagnani
no flags Details

Description antonio montagnani 2015-02-01 11:17:04 UTC
Description of problem:
Not able to print from a remote printer

Version-Release number of selected component (if applicable):
cups-1.7.5-13.fc21.x86_64

How reproducible:
always

Steps to Reproduce:
1.try to print from a remote computer
2.
3.

Actual results:
no print, I get a windows saying that there is an error in CUPSS server. An error occurred during CUPS operation: destination socket is not connected

Expected results:
just print

Additional info:
standard workstation F21 installations, printer is a Samsung ML-1610, furthermore it should show up in the remote computer printer windows with no action from operator

Comment 1 antonio montagnani 2015-02-01 11:22:25 UTC
Created attachment 986700 [details]
debug file from local printer

hope it can help. Printer is shared al least on the settings page

Comment 2 antonio montagnani 2015-02-01 11:23:56 UTC
of course it must be read as no printing from remote computer

Comment 3 antonio montagnani 2015-02-01 14:32:14 UTC
Bug 1087052 was very similar.
Furthermore I cannot delete old printers from available list in system-config-printer...I get CUPS forbidden!!!

If I connect the printer to any computer on the network it works fine...

Comment 4 antonio montagnani 2015-02-01 14:51:58 UTC
I checked the Firewall settings and I found that in Fedora-Workstation zone ipp and ipp-client were unchecked.

I checked them and everything worked fine: I guess that change of settings should be requested when a printer is shared (and F20 had this feature, I remember). Am I correct???

Comment 5 Chris Murphy 2015-02-02 06:11:52 UTC
I wonder if this is a firewalld-config-workstation (and firewalld-config-standard) bug instead of CUPS? If ipp-client isn't enabled, but should be, it seems that's the problem to fix it. I've inquired on desktop@ what the intended behavior is here. At the moment I think this must be unintentional behavior, people need to be able to discover and print to available network printers out of the box. firewall-config isn't installed by default on Fedora Workstation (or probably most spins) so the combination of ipp-client not enabled and no firewall-config is not good.

Comment 6 Tim Waugh 2015-02-02 11:40:43 UTC
The problem is that, while system-config-printer is Python3, firewalld's client bindings are not.

Comment 7 Fedora Update System 2015-02-02 13:47:08 UTC
firewalld-0.3.13-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/firewalld-0.3.13-2.fc21

Comment 8 Fedora Update System 2015-02-03 12:04:44 UTC
Package firewalld-0.3.13-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.13-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1598/firewalld-0.3.13-2.fc21
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-02-05 05:24:36 UTC
firewalld-0.3.13-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 poma 2015-02-08 21:56:17 UTC
Also, as related
"Requires python3-firewall"
http://pkgs.fedoraproject.org/cgit/system-config-printer.git/commit/?id=c69f03b

Thanks.


Note You need to log in before you can comment on or make changes to this bug.