Bug 1188159 - Version mismatch between httpd-itk and httpd
Summary: Version mismatch between httpd-itk and httpd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: httpd-itk
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1207858 (view as bug list)
Depends On: 1059143
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-02 08:01 UTC by Vladimir Stackov
Modified: 2015-04-12 18:11 UTC (History)
3 users (show)

Fixed In Version: httpd-itk-2.4.7.01-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-12 18:11:42 UTC


Attachments (Terms of Use)
Patch to fix build issue on EL7 (rhbz# 1188159) (1.66 KB, application/mbox)
2015-02-03 16:17 UTC, Othman Madjoudj
no flags Details

Description Vladimir Stackov 2015-02-02 08:01:23 UTC
Description of problem:
Version mismatch between httpd-itk and httpd:
# rpm -qa | grep -P 'httpd(-itk)?'
httpd-tools-2.4.6-19.el7.centos.x86_64
httpd-2.4.6-19.el7.centos.x86_64
httpd-itk-2.2.22-9.el7.x86_64

Version-Release number of selected component (if applicable):
2.2.22-9

How reproducible:
100%

Steps to Reproduce:
1. # yum -y install httpd httpd-itk
2. # httpd.itk -t

Actual results:
httpd.itk: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.modules.d/00-base.conf: Cannot load /etc/httpd/modules/mod_access_compat.so into server: /etc/httpd/modules/mod_access_compat.so: undefined symbol: ap_hook_check_access

Expected results:
Syntax OK

Comment 1 Othman Madjoudj 2015-02-03 16:15:42 UTC
HTTP-ITK 2.4.7-02 requires Apache httpd 2.4.7, EL7 has only 2.4.6.

According to RHBZ #1059143, httpd-2.4.6-21.el7 will have some backported patches required to run and build ITK.

I'll attached a patch for the maintainer (I'll be happy to co-maintain this packages if your time is limited).

Comment 2 Othman Madjoudj 2015-02-03 16:17:29 UTC
Created attachment 987680 [details]
Patch to fix build issue on EL7 (rhbz# 1188159)

Comment 3 Pavel Alexeev 2015-03-06 14:34:59 UTC
Thank you for your bugreport and willing make free software better!

Especially thank you for the patch and sorry for the delay. I'll look on it.

Comment 4 Fedora Update System 2015-03-06 20:47:50 UTC
httpd-itk-2.4.7.01-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/httpd-itk-2.4.7.01-5.el7

Comment 5 Pavel Alexeev 2015-03-06 20:49:50 UTC
Athmane thank you very much for the work.

Comment 6 Othman Madjoudj 2015-03-06 21:20:49 UTC
(In reply to Pavel Alexeev (aka Pahan-Hubbitus) from comment #5)
> Athmane thank you very much for the work.

No problem Pavel, happy to help. If you could review a small Apache module I'd very appreciate it (review stuck for ~11 months).

mod_ruid2 => https://bugzilla.redhat.com/show_bug.cgi?id=1089561

Comment 7 Fedora Update System 2015-03-08 22:39:07 UTC
Package httpd-itk-2.4.7.01-5.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing httpd-itk-2.4.7.01-5.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-1040/httpd-itk-2.4.7.01-5.el7
then log in and leave karma (feedback).

Comment 8 Pavel Alexeev 2015-03-12 22:02:31 UTC
I'll review it.

Comment 9 Othman Madjoudj 2015-03-31 21:34:44 UTC
*** Bug 1207858 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2015-04-12 18:11:42 UTC
httpd-itk-2.4.7.01-5.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.