Bug 118818 - xfs isn't configured to start on boot after upgrading XFree86 to xorg-x11
xfs isn't configured to start on boot after upgrading XFree86 to xorg-x11
Status: CLOSED DUPLICATE of bug 118145
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-20 20:44 EST by James Walton
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Walton 2004-03-20 20:44:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
After replacing the XFree86 packages with the xorg-x11 ones, X would
not start when I logged out.  It would infintely crash, once I
switched runlevels I determined 2 problems:
1. /usr/X11R6/lib was not in /etc/ld.so.conf so it couldn't find the
libraries
2. It was unsuccessfully connecting to xfs because it wasn't started.

After fixing these 2 problems X started fine, but on each subsequent
reboot I would have to manually start xfs for X to start.

Version-Release number of selected component (if applicable):
xorg-x11-xfs-0.0.6.6-0.0.2004_03_11.6

How reproducible:
Didn't try

Steps to Reproduce:
1. Install xorg-x11 packages over XFree86 packages with rpm -Uvh
2. Reboot
3.
    

Actual Results:  X doesn't start, I have to ssh to my box and switch
runlevels to start xfs first.

Expected Results:  xfs should be configured to start up

Additional info:

Got help on IRC from karsten__
# chkconfig --list xfs
service xfs supports chkconfig, but is not referenced in any runlevel
(run 'chkconfig --add xfs')

Running this fixes the problem
# /sbin/chkconfig --add xfs
Comment 1 Karsten Hopp 2004-03-20 20:52:44 EST
xorg-x11 obsoletes XFree86-xfs, thus causing a deinstallation 
of XFree86-xfs -> %preun xfs (XFree86-xfs) kicks in. 
Unfortunately %preun (XFree86-xfs) gets called after  
%post (xorg-x11-xfs), runs chkconfig --del xfs and you end up 
with a system where xfs is installed, but disabled. 
 
Comment 2 Bill Nottingham 2004-03-22 21:29:10 EST
This is covered along with the library path in bug 118448

*** This bug has been marked as a duplicate of 118448 ***
Comment 3 Mike A. Harris 2004-03-22 21:57:48 EST
Actually, this is a dupe of bug #118145


*** This bug has been marked as a duplicate of 118145 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.