Bug 1188186 - dnf ignores base.conf.cachedir when set after calling read_all_repos()
Summary: dnf ignores base.conf.cachedir when set after calling read_all_repos()
Status: CLOSED DUPLICATE of bug 1184943
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-02 09:53 UTC by Jakub Filak
Modified: 2016-12-01 00:48 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-02-13 10:38:36 UTC


Attachments (Terms of Use)

Description Jakub Filak 2015-02-02 09:53:15 UTC
Description of problem:
I've been playing with dnf and found out I have to set dnf.Base.conf.cachedir to a desired value before I call dnf.Base.read_all_repos() otherwise my script dies with an exception. See Bug 1184943 comment 2 for more details.

Version-Release number of selected component (if applicable):
dnf-0.6.3-2.fc21.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
dnf uses the system directory for its cache

Expected results:
dnf uses the provided directory for its cache or dnf documentation reflects this fact (or you can switch from dnf.Base.conf.cachedir variable to dnf.Base.conf.cachedir() function and spit a warning).

Comment 1 Michal Luscon 2015-02-13 10:38:36 UTC

*** This bug has been marked as a duplicate of bug 1184943 ***


Note You need to log in before you can comment on or make changes to this bug.