Bug 118823 - man page for Xnest is not verbose enough
man page for Xnest is not verbose enough
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-21 00:07 EST by Michael Longval
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 17:40:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Longval 2004-03-21 00:07:51 EST
Description of problem:

I banged my head against an access control problem for the Xnest
display.  ie I would create the Xnest display with "Xnest :1 &" and
then try "xterm -display :1" and would have access refused.

The man page for Xnest is no help at all.

I did NOT RTFM for Xserver as it suggested (I read the Xnest man page
too quickly).  I only found the suggested fix:

"Xnest :1 -ac" on a Debian help group.  

When I did Xnest -h the -ac option disappeared off the top of the
screen.... and doing SHIFT-UP does not get me the offscreen stuff
because I use the GNU-screen terminal multiplexer... (sic!)

I finally RTFMed the Xnest man page that suggested RTFMing the Xserver
man page where finally I saw that the -ac and a myriad of other
options are listed.... 

I would suggest just copy/pasting the Xserver details into the Xnest
man page.  It might take 10K more disk space AT MOST.

Version-Release number of selected component (if applicable):

Fedora Core 1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2004-03-23 17:40:29 EST
Documentation requests of this nature should always be made to the
upstream project.  I wont make a change like this in Red Hat
packaging because:

1) It creates duplication of documentation, which must then be kept
   in sync every time the documentation is updated, which is largely
   prone to human error.

2) It is the type of change that should be done upstream, rather
   than by Red Hat or other distributions, so that it is in one
   place.  Upstream is unlikely to accept such a request for change
   due to my point #1 above.

3) Because upstream is unlikely to accept such a change, if I were
   to add the change locally in Red Hat packaging, it would increase
   the amount of package maintenance overhead as Red Hat would have
   to then maintain the modified documentation indefinitely, and
   track all changes made to the documentation upstream and merge
   the changes in multiple locations in our forked documentation.

4) There is no real major benefit to this change.  The documentation
   does refer to other documentation which contains the proper
   up to date information.

Closing request for enhancement as 'WONTFIX', however feel free to
request these changes upstream at:  http://bugs.freedesktop.org
if you would like to get an upstream opinion as well.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.