Bug 118826 - "kernel panic: Attempted to kill init!"
Summary: "kernel panic: Attempted to kill init!"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: SysVinit   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-21 06:53 UTC by Jonathan Kamens
Modified: 2014-03-17 02:43 UTC (History)
2 users (show)

Fixed In Version: 2.85-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 17:24:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2004-03-21 06:53:52 UTC
After upgrading to SysVinit-2.85-20, I can no longer boot. 
Immediately after my initrd finishes running, I get "kernel panic:
Attempted to kill init!".  I had to reboot with init=/bin/sh, mount
all my filesystems by hand and downgrade to SysVinit-2.85-18 to get
back up and running.

It may be relevant that I'm *not* using SELinux.

Comment 1 Bill Nottingham 2004-03-22 06:34:04 UTC
But you probably have an /etc/sysconfig/selinux with
'SELINUX=enforcing', yes?

Or do you have 'enforcing=1' in your kernel commandline?

Comment 2 Enrico Scholz 2004-03-22 08:24:17 UTC
Happens here also with a vanilla 2.4.25 host. SELinux settings are the
default ones and there is no 'enforcing=1' in the cmdline (or any
other selinux option).

Comment 3 Bill Nottingham 2004-03-22 17:14:03 UTC
'default ones' -> do you have a /etc/sysconfig/selinux?

Comment 4 Enrico Scholz 2004-03-22 21:18:33 UTC
no; there is no /etc/sysconfig/selinux

Comment 5 Bill Nottingham 2004-03-22 21:49:34 UTC
Jonathan: are you running a 2.4 kernel as well?

Comment 6 Jonathan Kamens 2004-03-23 00:07:30 UTC
I am running 2.4.25-pac1 (built it myself, not Red Hat kernel).


Comment 7 Bill Nottingham 2004-03-23 02:20:08 UTC
OK, I can't reproduce this with the FC1 update kernel - does that work
for you? I'll build a 2.4.25 and test that...

Comment 8 Jonathan Kamens 2004-03-23 14:33:11 UTC
I am not in a position (i.e., I don't have the time) to try a FC 
kernel right now.


Comment 9 Bill Nottingham 2004-03-23 17:24:47 UTC
should be fixed in SysVinit-2.85-22. 


Note You need to log in before you can comment on or make changes to this bug.