Bug 118851 - XFree86config startup errors
XFree86config startup errors
Status: CLOSED DUPLICATE of bug 118448
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-21 11:37 EST by Dave
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave 2004-03-21 11:37:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
After updating from XFree86 4.3.0-63 to
xorg-x11-0.0.6.6-0.0.2004_03_11.6 I couldn't restart the xserver.
Ld.so.config had no reference to /usr/X11R6/lib, also XFree86config
was missing font paths extract from XFree86config
snip--------------------------------------------------------------- 
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection
end----------------------------------------------------------------
I rewrote this section to read
snip---------------------------------------------------------------
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	ModulePath   "/usr/X11R6/lib/modules"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
	FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
	FontPath     "/usr/X11R6/lib/X11/fonts/Speedo/"
	FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
	FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection
end----------------------------------------------------------------
Xserver now starts but exits with errors that the nvidia module cannot
be located.
I had to run XFree86 -configure to generate a device section which I
inserted into my XFree86config file. I still have a dep problem with
xine and aalib to work out.

Version-Release number of selected component (if applicable):
xorg-x11-0.0.6.6-0.0.2004_03_11.6

How reproducible:
Always

Steps to Reproduce:
1.update from XFree86 to xorg-x11
2.
3.
    

Expected Results:  Config files left intact
And links in the scripts to inform other packages that xorg-x11 = XFree86 

Additional info:
Comment 1 Mike A. Harris 2004-03-23 20:23:03 EST

*** This bug has been marked as a duplicate of 118448 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.