Bug 1188538 - perl-Fsdb-2.55-1.fc22 FTBFS: t/test_command.t tests fail
Summary: perl-Fsdb-2.55-1.fc22 FTBFS: t/test_command.t tests fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Fsdb
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: John Heidemann
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-03 07:50 UTC by Petr Pisar
Modified: 2015-02-28 10:23 UTC (History)
2 users (show)

Fixed In Version: perl-Fsdb-2.56-1.fc20
Doc Type: Bug Fix
Doc Text:
Cause: perl-Getopt-Long-2.43 is stricter than 2.42 Consequence: perl-Fsdb fails Fix: perl-Fsdb-2.56 now conforms Result: unicorns prance once again
Clone Of:
Environment:
Last Closed: 2015-02-06 07:02:30 UTC


Attachments (Terms of Use)

Description Petr Pisar 2015-02-03 07:50:42 UTC
perl-Fsdb-2.55-1.fc22 does not build in F22 because tests fail:

#   Failed test 'TEST/cgi_to_db_ex.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolcreate_double_creation.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolcreate_double_creation_ok.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolcreate_ex.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolcreate_ex_R.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolcreate_ex_S.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolcreate_first.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolcreate_new_default.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbcolpercentile_ex.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbcolpercentile_ex_S.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbcolpercentile_numeric.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolpercentile_rank.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbcolstats_ntile.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbcolstats_quartile.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbcolstats_quartile_even.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbcolstats_quartile_singleton.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbcolstats_quartile_truncation.cmd'
#   at t/test_command.t line 208.
#     test TEST/dbfilealter_compress_gzip.cmd skipped (disabled in .cmd)
#   Failed test 'TEST/dbfilepivot_commented.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbfilepivot_ex.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbfilepivot_hw_order.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_ex.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_ex_R.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_ex_S.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_missing_last_1.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_missing_last_2.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_multiples.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_non_matching.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_non_matching_2.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_unsorted.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbjoin_unsorted_pipe.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_compatible_fscodes.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_dbrowenumerate.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_ex.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_ex_S.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_external_file.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_external_with_key.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_external_with_key_no_input.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_grouped.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_grouped_incorrectly.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_incompatible_fscodes.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_limited_parallelism.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_limited_parallelism_2.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_multiple_aware.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_multiple_aware_code.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_multiple_aware_no_input.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_multiple_aware_sub_ungrouped.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_no_input.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_reducer_returns_key.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_sub.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_sub_code.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_sub_no_prepend.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmapreduce_sub_simple.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmapreduce_unlimited_parallelism.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmerge2_ex.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmerge2_ex_R.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmerge2_two_input.cmd'
#   at t/test_command.t line 208.
Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbmerge_17_input_endgame.cmd'
#   at t/test_command.t line 208.
Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbmerge_17_input_noendgame.cmd'
#   at t/test_command.t line 208.
Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbmerge_17_xargs.cmd'
#   at t/test_command.t line 208.
Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbmerge_20_delayed.cmd'
#   at t/test_command.t line 208.
Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbmerge_20_input.cmd'
#   at t/test_command.t line 208.
Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbmerge_20_input_parallel.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmerge_2_input.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmerge_3_input.cmd'
#   at t/test_command.t line 208.
Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbmerge_3_input_parallel.cmd'
#   at t/test_command.t line 208.
Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbmerge_5_input_endgame.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmerge_ex.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmerge_ex_R.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmerge_inputs.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmultistats_ex.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbmultistats_ex_S.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmultistats_grouped.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmultistats_grouped_incorrectly.cmd'
#   at t/test_command.t line 208.
dbfilediff: cannot open input: no header line
#   Failed test 'TEST/dbmultistats_quartile.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbpipeline_filter.cmd'
#   at t/test_command.t line 208.
dbfilediff: internal error, extra arguments.
 at blib/script/dbfilediff line 192.
#     test TEST/dbpipeline_first_fails failed, delta:
# *** TEST/dbpipeline_first_fails.altout	Sat Oct 12 02:12:46 2013
# --- TEST/dbpipeline_first_fails.trial	Mon Feb  2 12:22:31 2015
# ***************
# *** 1,2 ****
# ! dbcolcreate: cannot open input: no header line
# ! dbroweval: cannot open input: no header line
# --- 1 ----
# ! Option spec <> cannot be used with pass_through
#   Failed test 'TEST/dbpipeline_first_fails.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbpipeline_sink.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbpipeline_sink2.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_batched.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_comments.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_empty.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_ex.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_ex_R.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_ex_S.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_merge.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_numerically.cmd'
#   at t/test_command.t line 208.
#   Failed test 'TEST/dbsort_reversed.cmd'
#   at t/test_command.t line 208.
#    test blib/script/xml_to_db -k files/file  < TEST/xml_to_db_ex.in skipped because of missing module XML::Simple
# #### output of some failed tests
# # TEST/cgi_to_db_ex
# 	*** TEST/cgi_to_db_ex.out	Mon Jan 26 22:42:35 2009
# 	--- TEST/cgi_to_db_ex.trial	Mon Feb  2 12:21:44 2015
# 	***************
# 	*** 1,16 ****
# 	! #fsdb -F S -R C name id email submit_time newfield emptyfield
# 	! name: test
# 	! id: 111-11-1111
# 	! email: test@usc.edu
# 	! submit_time: Tue Jan 14 11:32:39 2003
# 	! newfield: -
# 	! emptyfield: -
# 	! 
# 	! name: test2
# 	! id: 222-22-2222
# 	! email: test2@usc.edu
# 	! submit_time: Tue Jan 24 22:32:39 2003
# 	! newfield: foo
# 	! emptyfield: -
# 	! 
# 	! #   | cgi_to_db TEST/cgi_to_db_ex.in TEST/cgi_to_db_ex.in-2
# 	--- 1 ----
# 	! Option spec <> cannot be used with pass_through
# # TEST/dbcolcreate_double_creation
# 	*** TEST/dbcolcreate_double_creation.out	Tue Nov  4 07:15:23 2014
# 	--- TEST/dbcolcreate_double_creation.trial	Mon Feb  2 12:21:46 2015
# 	***************
# 	*** 1,2 ****
# 	! dbcolcreate: attempt to create pre-existing column foo.
# 	!  at blib/script/dbcolcreate line 999.
# 	--- 1 ----
# 	! Option spec <> cannot be used with pass_through
# # TEST/dbcolcreate_double_creation_ok
# 	*** TEST/dbcolcreate_double_creation_ok.out	Thu Jun 26 18:06:44 2014
# 	--- TEST/dbcolcreate_double_creation_ok.trial	Mon Feb  2 12:21:47 2015
# 	***************
# 	*** 1,4 ****
# 	! #fsdb test foo
# 	! a	-
# 	! b	-
# 	! #   | dbcolcreate --no-recreate-fatal foo foo
# 	--- 1 ----
# 	! Option spec <> cannot be used with pass_through
# # TEST/dbcolcreate_ex
# 	*** TEST/dbcolcreate_ex.out	Mon Jan 26 22:42:35 2009
# 	--- TEST/dbcolcreate_ex.trial	Mon Feb  2 12:21:47 2015
# 	***************
# 	*** 1,4 ****
# 	! #fsdb test foo
# 	! a	-
# 	! b	-
# 	! #   | dbcolcreate foo
# 	--- 1 ----
# 	! Option spec <> cannot be used with pass_through
# Looks like you failed 87 tests of 277.
t/test_command.t .. 
Dubious, test returned 87 (wstat 22272, 0x5700)

Difference between working and failing build root:

        perl-Getopt-Long 	2.42-310.fc22 	> 	2.43-1.fc22
	perl-Test-Harness 	3.34-1.fc22 	> 	3.35-1.fc22
	perl-Pod-Simple 	1:3.28-310.fc22 	> 	1:3.29-1.fc22
	info 	5.2-7.fc22 	> 	5.2-8.fc22
	perl-HTTP-Tiny 	0.053-1.fc22 	> 	0.054-1.fc22
	setup 	2.9.4-1.fc22 	> 	2.9.5-1.fc22
	libgpg-error 	1.17-1.fc22 	> 	1.17-2.fc22
	gnupg2 	2.1.1-1.fc22 	> 	2.1.1-2.fc22
	patch 	2.7.3-1.fc22 	> 	2.7.4-1.fc22
	kernel-headers 	3.19.0-0.rc6.git2.1.... 	> 	3.19.0-0.rc6.git3.1....

Comment 1 John Heidemann 2015-02-04 05:32:14 UTC
Yes, I can reproduce this on rawhide (not on F21).  I'll take a look.

Comment 2 John Heidemann 2015-02-04 06:03:28 UTC
Will be fixed in Fsdb-2.56, currently cranking through Koji.

Comment 3 Fedora Update System 2015-02-04 06:24:38 UTC
perl-Fsdb-2.56-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/perl-Fsdb-2.56-1.fc21

Comment 4 Fedora Update System 2015-02-04 06:25:11 UTC
perl-Fsdb-2.56-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/perl-Fsdb-2.56-1.el7

Comment 5 Fedora Update System 2015-02-05 05:25:28 UTC
Package perl-Fsdb-2.56-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Fsdb-2.56-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1714/perl-Fsdb-2.56-1.fc21
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-02-19 18:02:37 UTC
perl-Fsdb-2.56-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-02-19 19:36:01 UTC
perl-Fsdb-2.56-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-Fsdb-2.56-1.fc20

Comment 8 Fedora Update System 2015-02-20 20:41:34 UTC
perl-Fsdb-2.56-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 John Heidemann 2015-02-20 21:50:54 UTC
Btw, the change in perl-Getopt-Long that triggered this bug in perl-Fsdb apparently propagated across f20 and f21, not just rawhide.  So this upgrade is needed across the board.  The F20 change is in testing... is there an easy way to shortcut the week of quiet time to get it in stable?

Comment 10 Jason Tibbitts 2015-02-21 00:57:50 UTC
It should push much sooner if the update can get three positive karma.

Comment 11 Fedora Update System 2015-02-28 10:23:05 UTC
perl-Fsdb-2.56-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.