Bug 118860 - X starts but no display on ati rage mobility and dell inspiron 7500
X starts but no display on ati rage mobility and dell inspiron 7500
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-21 14:00 EST by Thomas J. Baker
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 18:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/XFree86.0.log (38.51 KB, text/plain)
2004-03-21 14:01 EST, Thomas J. Baker
no flags Details
lspci -vv (5.45 KB, text/plain)
2004-03-21 14:02 EST, Thomas J. Baker
no flags Details
xorg.conf (2.70 KB, text/plain)
2004-05-11 21:32 EDT, Thomas J. Baker
no flags Details
system-config-display --reconfig error (2.50 KB, text/plain)
2004-05-11 21:34 EDT, Thomas J. Baker
no flags Details
Xorg.0.log (36.96 KB, text/plain)
2004-05-11 21:34 EDT, Thomas J. Baker
no flags Details
/var/log/messages from two boots (49.15 KB, text/plain)
2004-05-11 21:35 EDT, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2004-03-21 14:00:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.13

Description of problem:
After upgrading to the xorg-x11 server, X starts but doesn't display
anything on my Dell Inspiron 7500. The screen is just black. I tried
booting with nofb but that didn't help. 

Version-Release number of selected component (if applicable):
xorg-x11-0.0.6.6-0.0.2004_03_11.6

How reproducible:
Always

Steps to Reproduce:
1. install xorg-x11
2. startx
3.
    

Actual Results:  X starts but the screen is just black. 

Expected Results:  X starts and draws the desktop or login screen.

Additional info:
Comment 1 Thomas J. Baker 2004-03-21 14:01:17 EST
Created attachment 98740 [details]
/var/log/XFree86.0.log
Comment 2 Thomas J. Baker 2004-03-21 14:02:20 EST
Created attachment 98741 [details]
lspci -vv
Comment 3 Thomas J. Baker 2004-03-31 10:30:05 EST
a clean install of fc2t2 doesn't help.
Comment 4 John Dennis 2004-04-01 17:19:04 EST
Could you please attach a copy of the file /var/log/XFree86.0.log
after the failure. Also please take a peek at /var/log/messages and
see if there is anything suspicious, but the most important thing is
the X server log file.
Comment 5 John Dennis 2004-04-01 17:20:46 EST
I'm sorry, you already attached the log file, my mistake.
Comment 6 Thomas J. Baker 2004-04-09 08:38:48 EDT
I got the ATI driver to work by adding vga=792 to the kernel command
line. I remembered from years ago that that was a fix when I first
started installing RH on Dell laptops. So it's not a perfect fix but
my laptop is now more than a paper weight.
Comment 7 Mike A. Harris 2004-05-05 17:09:00 EDT
According to the X server log file attached to this report, you
are using a non-Red Hat custom built kernel.  Please update your
installation to the latest rawhide packages available so that you're
running our latest testing codebase, and boot into the official
Red Hat kernel.

If you are able to reproduce this problem using an official Red Hat
built kernel, please attach your X server log and config file, and
/var/log/messages as individual uncompressed file attachments using
the link below, and we will try to troubleshoot further.

Thanks in advance.

Comment 8 Thomas J. Baker 2004-05-06 06:37:37 EDT
This system has always been running a Red Hat kernel. From the log:

OS Kernel: Linux version 2.6.3-2.1.253.2.1
(bhcompile@tweety.devel.redhat.com) (gcc version 3.3.3 20040216 (Red
Hat Linux 3.3.3-2.1)) #1 Fri Mar 12 14:01:55 EST 2004
Comment 9 Mike A. Harris 2004-05-07 10:21:34 EDT
Oops, I was requesting the same info in 2 bug reports, one of which
had a non-Red Hat kernel, and I must have gotten the two crossed.

We still need your config file used during this problem, and the
/var/log/messages file however.  I'll review this again once
they're attached.

Thanks in advance.
Comment 10 Thomas J. Baker 2004-05-11 21:28:45 EDT
Just to update, I'm running current rashide from 11 May including
xorg-x11-6.7.0-2 and kernel-2.6.5-1.358. If I don't have vga=792 on
the kernel command line, I don't get anything displayed. I'm going to
attach the config file, the error I get when I try to reconfig the
display, the xorg log file, and the /var/log/messages with two boots.
The first without vga=792 and the second with.
Comment 11 Thomas J. Baker 2004-05-11 21:32:28 EDT
Created attachment 100170 [details]
xorg.conf
Comment 12 Thomas J. Baker 2004-05-11 21:34:01 EDT
Created attachment 100171 [details]
system-config-display --reconfig error
Comment 13 Thomas J. Baker 2004-05-11 21:34:46 EDT
Created attachment 100172 [details]
Xorg.0.log
Comment 14 Thomas J. Baker 2004-05-11 21:35:19 EDT
Created attachment 100173 [details]
/var/log/messages from two boots
Comment 15 Thomas J. Baker 2004-05-11 21:39:43 EDT
I just did a diff on the xorg log files between non working and
working. There are slight differences as one was started from run
level 3 using startx while the other was started normally from run
level 5 but the panel dimensions and write combining stuff could be
where the problem lies.

[root@millennium tmp]# diff Xorg.0.log /var/log/Xorg.0.log
16c16
< (==) Log file: "/var/log/Xorg.0.log", Time: Tue May 11 21:12:48 2004
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Tue May 11 21:18:06 2004
54c54
< (--) using VT number 7
---
> (++) using VT number 7
424c424,425
< (WW) ATI(0): Inconsistent panel horizontal dimension:  1400 and 1401.
---
> (WW) ATI(0): Inconsistent panel horizontal dimension:  1400 and 1399.
> (WW) ATI(0): Inconsistent panel vertical dimension:  1050 and 1049.
435c436
< (==) ATI(0): Write-combining range (0xfd000000,0x800000)
---
> (WW) ATI(0): Failed to set up write-combining range
(0xfd000000,0x800000)
443c444
< (!!) ATI(0): Conflicting XF86Config VertRefresh specification(s)
ignored.
---
> (WW) ATI(0): Extraneous XF86Config VertRefresh specification(s) ignored.
655c656
< (==) ATI(0): Write-combining range (0xfd000000,0x800000)
---
> (WW) ATI(0): Failed to set up write-combining range
(0xfd000000,0x800000)
700c701,703
< AUDIT: Tue May 11 21:13:09 2004: 24533 X: client 5 rejected from
local host
---
> GetModeLine - scrn: 0 clock: 107859
> GetModeLine - hdsp: 1400 hbeg: 1448 hend: 1560 httl: 1688
>               vdsp: 1050 vbeg: 1051 vend: 1054 vttl: 1066 flags: 5
[root@millennium tmp]#
Comment 16 des johnston 2004-05-22 04:42:28 EDT
A Dell Inspiron 5000 with a working 1400x1050 configuration in FC1
also requires vga=792 to get anything on screen after an upgrade to FC2
(release). X starts but screen is blank otherwise.

Similar "Inconsistent panel horizontal dimension" messages to above 
in Xorg.0.log
Comment 17 Trevor Harmon 2004-06-02 19:36:54 EDT
Just wanted to say that I also have a Dell Inspiron 7500, and I was
seeing the exact same problem that Thomas Baker reported here. I can
confirm this bug on Fedora Core 2 final (clean install).

Fortunately, his tip on passing the vga=792 option to the kernel works
like a charm. This option not only allowed me to run startX, but it
also allowed the Fedora Core 2 installer to run. (Without the option,
a blank screen is shown when the installer switches to graphical mode,
and it has to be run in text mode.)

Note that Thomas's xorg.conf also works perfectly for me and allowed
me to get up and running with FC2 on the Inspiron 7500.

Trevor
Comment 18 Mike A. Harris 2004-08-27 13:41:16 EDT
Does this problem occur with Fedora Core 3 test1 plus all Fedora
development updates, using xorg-x11-6.7.99.902-8?
Comment 19 Thomas J. Baker 2004-08-27 13:51:43 EDT
I tried it on the first CVS release you did a couple of days ago and
it didn't work. I reported the bug to Xorg bugzilla: 

https://freedesktop.org/bugzilla/show_bug.cgi?id=1109

but no updates to it have occured. I'll try the latest release this
weekend. (I would have tried it sooner but it didn't seem like the bug
was being addressed since there weren't any updates on the xorg bugzilla.)
Comment 20 Mike A. Harris 2004-08-27 14:19:28 EDT
Right now, Xorg is in finalization for 6.8.0, and any bug that is
not marked a blocker in bugzilla isn't being directly reviewed for
6.8.0.  I've marked the bug as a candidate for blocker, however
someone will review it and make a decision wether or not to
accept it as a release blocker.

I've added myself to CC on that bug, and we'll track the issue
in the upstream bugzilla now.  Thanks for reporting it there.

Setting status to "UPSTREAM"
Comment 21 jim mcabee 2004-09-14 08:37:16 EDT
Has this bug been fixed?
Comment 22 Mike A. Harris 2004-09-14 08:48:25 EDT
According to the upstream bug report, it has not yet been investigated
by X.Org developers.  If you'd like to, you can track the bug report
by adding yourself to the CC on the upstream bug report however.  It
is located at:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118860

Hope this helps.
Comment 23 Trevor Harmon 2004-12-14 14:09:47 EST
Just wanted to note that comment #17 also applies to Fedora Core 3 final.
Comment 24 Frederik Seyns 2005-08-05 13:50:56 EDT
Hello,
I have the same problem with Fedora Core 4 on my Dell Inspiron 7500. 
I am new with Linux/ Fedora. The solution must be adding "vga = 792" to a file,
but witch file is it? I can't find the files called above. Are they renamed?
Using  a portable isn't very usefull if you have to connect another screen to it...
Comment 25 Thomas J. Baker 2005-08-05 16:09:26 EDT
It gets added to the kernel command line. You put it in /etc/grub.conf on the
kernel line of the kernel you want to boot.
Comment 26 Thomas J. Baker 2005-10-03 14:42:14 EDT
I'm reopening this bug for current rawhide because the upstream bug referenced
in comment #19 has been closed as fixed. Any hope of getting the patch added to
the current rawhide x11?
Comment 27 Mike A. Harris 2005-10-05 18:27:57 EDT
It's fixed in Xorg CVS HEAD according to the upstream bug report, which
means the X11R7 release will have the fix.  Fedora Core 5 will contain
X11R7, so the fix will automatically be in FC5, and will be available to
people when we integrate X11R7 into rawhide.

Setting status to "NEXTRELEASE" (FC5)

Note You need to log in before you can comment on or make changes to this bug.