Bug 118865 - esd crashed when loading xmms.
esd crashed when loading xmms.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-21 17:40 EST by Konrad Mrozek
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 22:45:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konrad Mrozek 2004-03-21 17:40:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
first when i installed fc 2 test 1 i couldn't load xmms. i noticed
that it was esound fault. than i run gdb esd and it print:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1207760480 (LWP 2379)]
0x004e971a in snd_pcm_hw_param_set_near () from /usr/lib/libasound.so.2



Version-Release number of selected component (if applicable):
esd-0.2.32 xmms-1.2.9

How reproducible:
Always

Steps to Reproduce:
1.gdb esd
2.run
3.
    

Actual Results:  Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1207760480 (LWP 2379)]
0x004e971a in snd_pcm_hw_param_set_near () from /usr/lib/libasound.so.2


Expected Results:  it should simply load. without output.

Additional info:

i've got athlon 2000+ on dfi ad77 and sb live 1024 player. i tried to
upgrade alsa-lib and esound but it didn't give any results. i read
xmms fault (segm fault) and i'm sure that it's not xmms fault. it's
esd fault because it's set as default output in xmms.
Comment 1 Warren Togami 2004-04-13 22:45:18 EDT
Please do a full upgrade to pure rawhide, I have been using xmms
extensively and have no seen anything like this problem.  REOPEN only
if pure rawhide exhibits this problem.

Note You need to log in before you can comment on or make changes to this bug.