Bug 1188675 - hosted-engine --deploy should query for its fqdn
Summary: hosted-engine --deploy should query for its fqdn
Keywords:
Status: CLOSED DUPLICATE of bug 1251968
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: 1.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: Yedidyah Bar David
QA Contact: Ilanit Stein
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-03 14:08 UTC by Yedidyah Bar David
Modified: 2019-04-28 13:40 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-28 14:55:53 UTC
oVirt Team: Integration
sbonazzo: ovirt-4.0.0?
sbonazzo: planning_ack?
sbonazzo: devel_ack+
sbonazzo: testing_ack?


Attachments (Terms of Use)

Description Yedidyah Bar David 2015-02-03 14:08:45 UTC
Description of problem:

hosted-engine --deploy silently uses its hostname (output of 'hostname') as the name to use when needing to contact it (the engine and/or other hosts).

It should ask the user what name to use, suggesting its hostname as default, explaining that this will be used to contact it by engine and host and thus needs to be resolvable by them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install an OS on a host, configure hostname that is not resolvable from outside
2. run hosted-engine --deploy
3.

Actual results:
The engine will fail to contact it

Expected results:
The user will input something that is resolvable and deploy will succeed

Additional info:

See also bug 1188663

Perhaps just one of them will be enough.

Comment 1 Yedidyah Bar David 2015-10-06 06:08:48 UTC
I think it's a bit more urgent than postponing to an undefined future release. IIRC we already had cases where this was an issue. Probably also quite an easy fix.

Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 11:01:17 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 3 Simone Tiraboschi 2015-10-28 14:55:53 UTC

*** This bug has been marked as a duplicate of bug 1251968 ***


Note You need to log in before you can comment on or make changes to this bug.