Bug 11889 - Install fails: anaconda/python error
Install fails: anaconda/python error
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-03 21:38 EDT by reddytm
Modified: 2016-11-14 11:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-03 21:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description reddytm 2000-06-03 21:38:34 EDT
Hello,
I am trying to install V6.1 on a Dell Dimension XPS T600r running Win98.
I have partioned my hard drive into two parts of 7868 MB and 11602MB 
respectively using "fips.exe" provided with the package. I am trying to 
install linux in the second partion. I have downloaded the updates-RHEA-
1999_045.img and boot-RHEA-1999_045.img too from the ftp site and used 
rawrite to create the boot disks.

I tried running the install in gui mode and it came with the following 
error:
An error occured No valid devices were found on which to create new 
filesystems. 

And when i used the text mode I got the following messages:
Traceback(innermost last):

File "/usr/bin/anaconda", line 225, in ?
intf.run(todo, test=test).

File "/tmp/updates/text.py", line 1009, in 
run rc=apply(step[1](), step[2])

File "/mnt/redhat/comps/install/6.1/1386/RedHat/instimage/usr/lib/python1.5
/site-packages/textw/partioning.py", line 116, in __call__

TypeError: list of strings

I bought the Official Redhat6.1 Standard edition. But the free online 
support expired before I could use it. I didn't work on the install as 
soon as I registered.

My system details are:
# P3 600MHz
# 20.4GB Ultra ATA Hard Drive, 7200RPM with a ATA 66 controller card
# 128MB SDRAM with ECC
# 32MB NVIDIA TNT2 M64 Graphics Card

I tried to give you all the possible details. Please let me know if you 
need anything else.

Please help me!
Thanks in advance
Tarak
Comment 1 Brock Organ 2000-06-10 00:12:59 EDT
thank you for your report... unfortunately, we could not reproduce this problem
in our tests; this issue may be hardware specific ...

(ie 
 - we created a full drive win 32 vfat partition on a 12 Gb drive
 - used fips to partition the partition into two partitions
	drive partition 1: 7867 Mb  (Win95 VFAT 32)
	drive partition 2: 5075 Mb  (Win95 VFAT 32)
 - booted into the 6.1 installer
 - both drive partitions 1 & 2 are available to the installer (ie no exception
or error about 'no valid devices found'...)
)
Comment 2 Brock Organ 2000-06-10 00:14:26 EDT
tarak,

before you used fips to partition your drive, did you try to boot the 6.1
installer?  Did you get the same error about 'No valid devices found' ...?

brock
Comment 3 openshift-github-bot 2016-11-14 11:46:06 EST
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/afb4f8d9e2c31ae409481edd14297deb9dbaadc0
Merge pull request #11898 from jim-minter/issue11889

Merged by openshift-bot

Note You need to log in before you can comment on or make changes to this bug.