Bug 118893 - 'Who' and 'w' outputs wrong logged in users
Summary: 'Who' and 'w' outputs wrong logged in users
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sh-utils   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-22 15:57 UTC by Brigasta
Modified: 2007-04-18 17:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 09:40:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brigasta 2004-03-22 15:57:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I log in from tty1,tty2,tty3 and a remote telnet terminal and I 
exec 'WHO' or 'W' command:

it displays:

tty1  ....
tty2  ....
tty3  ....
pts/0 ....

Then I log in from another remote telnet terminal and I re-exec 'WHO' 
or 'W' command:

it displays:

pts/1 ....
tty2  ....
tty3  ....
pts/0 ....

tty1 is still logged in but who command doesn't show it! Moreover 
pts/1 has taken its place! When I log out pts/1, tty1 will no more be 
shown again!

I suppose bug depends on 'login' and '/var/run/utmp' file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:


    

Additional info:

Comment 1 Tim Waugh 2004-03-22 17:38:46 UTC
Does this happen for you with Red Hat Enterprise Linux, say, or Fedora
Core 1?  7.2 is quite an old release and many bugs have been fixed
since then.

Comment 2 Brigasta 2004-03-23 08:44:48 UTC
It happens on RH Linux 7.2 and 7.3 but not in 9.0. I know it's a 
previous version but I'd like to solve the problem without upgrading.


Note You need to log in before you can comment on or make changes to this bug.