Bug 118898 - Unable to start root applications as normal user
Unable to start root applications as normal user
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-22 11:52 EST by Daniel Malmgren
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-30 10:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2004-03-22 11:52:01 EST
Description of problem:
Up till last week I have been able to start applications that requires
root privilegies as normal user, the program just asks for the root
password in a nice requester and remembers that I have root
privilegies for a period of time (showing those nice little keys in
the notification area). However suddenly this behaviour has stopped.
Nothing happens when I try to start those applications.

Version-Release number of selected component (if applicable):
pam-0.77-38

How reproducible:
100%

Steps to Reproduce:
1. Log in as non root user
2. Try to start a program that requires root privilegies

Actual results:
Nada.

Expected results:
Ask me for root password and then start (supposing I give it the
correct password).

Additional info:
I get the following in my /var/log/messages each time I try this:
Mar 22 17:55:31 Datorn system-config-network(pam_unix)[2930]: auth
could not identify password for [root]

Also tried downgrading pam to 0.77-36 (which has worked before), but
it doesn't do any good, so I'm not sure this has with pam to do at
all. Don't know where else to file it though...
Comment 1 Daniel Malmgren 2004-04-30 10:56:49 EDT
Seems to work with latest versions. Closing.

Note You need to log in before you can comment on or make changes to this bug.