Bug 118901 - Xfree86 Crashes on Logout
Xfree86 Crashes on Logout
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-22 12:03 EST by George Skuse
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-22 14:50:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of the X Crash (output from startx) (2.80 KB, text/plain)
2004-03-22 12:04 EST, George Skuse
no flags Details
Xfree86.0.log (40.70 KB, text/plain)
2004-03-22 12:05 EST, George Skuse
no flags Details
My XF86Config file (3.84 KB, text/plain)
2004-03-22 12:06 EST, George Skuse
no flags Details

  None (edit)
Description George Skuse 2004-03-22 12:03:11 EST
Description of problem:
My setup is a Pentium4 w/ an NVidia GeForceFX 5200 Dual monitor card
w/ 2 VGA monitors attached.  I'm starting X via startx from the
command line.  Attempting to log out always results in a crash.  The
most relevant error message seems to be:

The program 'gnome-session' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1242 error_code 8 request_code 1 minor_code 0)

I've attached a log of the startx command as well as my XF86Config and
XFree86.0.log files.  This has been happening for a while.  I upgraded
to gnome-session 2.4.2-1 from 2.4.0-1 to see if this would solve the
problem: it didn't.

Relevant install packages:
   XFree86-4.3.0-55
   gnome-panel-2.4.2-3
   gnome-session-2.4.2-1
   kernel-2.4.22-1.2140.nptl
   nvidia driver 1.0-5336

Version-Release number of selected component (if applicable):
XFree86-4.3.0-55

How reproducible:
Always

Steps to Reproduce:
1.Start X with startx (I'm using gnome)
2.Chose "Log Out" from the hat menu

 
Actual Results:  X Crashes and I'm thrown to the bash command line. 
An error message (described above) is displayed.

Expected Results:  The screen should dim and the Log out Dialog box
should appear
Comment 1 George Skuse 2004-03-22 12:04:10 EST
Created attachment 98749 [details]
Log of the X Crash (output from startx)
Comment 2 George Skuse 2004-03-22 12:05:35 EST
Created attachment 98750 [details]
Xfree86.0.log
Comment 3 George Skuse 2004-03-22 12:06:07 EST
Created attachment 98751 [details]
My XF86Config file
Comment 4 Mike A. Harris 2004-03-22 14:50:16 EST
You are using custom built XFree86 packages on your system rather
than the ones that Red Hat provides.  Red Hat does not support
user recompiled packages.  Also, your system is using 3rd party
kernel modules, which Red Hat also does not support.

Please remove the custom built XFree86 packages, and reinstall
the binary rpms supplied by Red Hat, then disable all 3rd party
kernel modules from loading at or after boot time, and reboot
your system.  Once the system has been rebooted cleanly without
loading any 3rd party kernel modules, if you are able to reproduce
this problem using the Red Hat supplied packages, please feel
free to attach the X server log and config file from the new
X session, as well as your /var/log/messages file containing all
boot messages since the system was booted.  Also attach the output
of "lsmod" and "lspci -vvn".

Closing as "NOTABUG" for now, as we do not support systems using
3rd party kernel modules or recompiled system packages like XFree86.

Note You need to log in before you can comment on or make changes to this bug.