Bug 1189034 - "an internal error has occurred" during ipa host-del --updatedns
Summary: "an internal error has occurred" during ipa host-del --updatedns
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Martin Bašti 🖰
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks: 1198431
TreeView+ depends on / blocked
 
Reported: 2015-02-04 09:58 UTC by Kaleem
Modified: 2019-05-20 11:29 UTC (History)
8 users (show)

Fixed In Version: ipa-4.2.0-0.1.alpha1.el7
Doc Type: Known Issue
Doc Text:
The "ipa host-del --updatedns" command does not update the host DNS records if the DNS zone of the host is not fully qualified. Creating unqualified zones was possible in Red Hat Enterprise Linux 7.0 and 6. If you execute "ipa host-del --updatedns" on an unqualified DNS zone, for example, "example.test" instead of the fully qualified "example.test.", the command fails with an internal error and deletes the host but not its DNS records. To work around this problem, execute the "ipa host-del --updatedns" command on an IdM server running Red Hat Enterprise Linux 7.0 or 6, where updating the host DNS records works as expected, or update the host DNS records manually after running the command on Red Hat Enterprise Linux 7.1.
Clone Of:
: 1198431 (view as bug list)
Environment:
Last Closed: 2015-11-19 12:01:16 UTC


Attachments (Terms of Use)
console output and httpd error log (5.04 KB, text/plain)
2015-02-04 09:58 UTC, Kaleem
no flags Details
Verify log for bz (7.22 KB, text/plain)
2015-08-31 09:23 UTC, Pavel Picka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2362 normal SHIPPED_LIVE ipa bug fix and enhancement update 2015-11-19 10:40:46 UTC

Description Kaleem 2015-02-04 09:58:03 UTC
Created attachment 987994 [details]
console output and httpd error log

Description of problem:
Saw following error on console while doing "ipa host-del" using "--updatedns" on RHEL-7.1 based machine which was enrolled as replica to RHEL-6.6 based master.

[root@vm-idm-004 ~]# ipa host-del --updatedns testhostBZ910468.testrelm.test
ipa: ERROR: an internal error has occurred
[root@vm-idm-004 ~]#

Same command works fine on RHEL-7.1 based IPA Master

[root@master ~]# ipa host-del --updatedns testhostBZ910468.testrelm.test
---------------------------------------------
Deleted host "testhostbz910468.testrelm.test"
---------------------------------------------
[root@master ~]#

Version-Release number of selected component (if applicable):
[root@vm-idm-004 ~]# rpm -q ipa-server
ipa-server-4.1.0-18.el7.x86_64
[root@vm-idm-004 ~]# 

How reproducible:
Always

Steps to Reproduce:
1. Install a RHEL-6.6 based IPA master
2. Enroll a RHEL-7.1 based replica from step(1) Master
3. Promote replica of step(2) as Master
4. Add a host using ipa host-add 

ipa host-add testhostBZ910468.testrelm.test --ip-address='10.65.206.140'

5. Delete host added in step(5)

ipa host-del --updatedns testhostBZ910468.testrelm.test

Actual results:
"ipa: ERROR: an internal error has occurred" shown on console

Expected results:
host should have been deleted successfully.

Additional info:
(1)Please find the attached snippet from /var/log/httpd/error_log for assertion error seen.

Comment 2 Martin Kosek 2015-02-04 16:33:26 UTC
Martin, can you please investigate this one?

Comment 3 Martin Bašti 🖰 2015-02-04 16:49:43 UTC
if zone in IPA 3.x was created without trailing dot, dnszone commands will fail

This fix should prevent this type of errors.
https://fedorahosted.org/freeipa/ticket/4722

Comment 4 Namita Soman 2015-02-04 17:29:27 UTC
Martin, Kaleem did not create a zone. His steps indicate he installed 6.6 server, 7.1 replica, and added a host, then deleted this host. So any zones created - are from what ipa-server install added. Why should a host-del error out in this case?

Kaleem, what bind-dyndb-version on 6.6 did you use? Were you using the build from 6.6.z - bind-dyndb-ldap-2.3-6.el6_6 ?

Comment 5 Martin Kosek 2015-02-04 19:37:07 UTC
Adding a zone by dnszone-add on RHEL-6.x or using the default zone installed together with IPA server does not matter - both are dotless and both will cause this issue on RHEL-7.1 replicas.

Comment 6 Martin Kosek 2015-02-05 14:24:40 UTC
Moving to POST, since we have a patch ready.

Comment 14 Pavel Picka 2015-08-31 09:23:37 UTC
Created attachment 1068564 [details]
Verify log for bz

Comment 15 Pavel Picka 2015-08-31 09:24:12 UTC
Verified

Comment 16 Kaleem 2015-08-31 11:19:53 UTC
Verified as per c14

Comment 17 errata-xmlrpc 2015-11-19 12:01:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html


Note You need to log in before you can comment on or make changes to this bug.