Bug 118906 - kscd crashes if no cddb record is found for a CD
kscd crashes if no cddb record is found for a CD
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-22 12:27 EST by Laszlo L. Tornoci
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 16:29:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KDE backtrace for Xscd (2.79 KB, text/plain)
2004-04-20 03:03 EDT, Landon Curt Noll
no flags Details

  None (edit)
Description Laszlo L. Tornoci 2004-03-22 12:27:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
kscd crashes every time an audio CD is put in the player if it doesn't find a cddb record for the CD. If remote cddb search is not configured, it will play the same CD without problem. However, it will not save manually entered cddb data into the local cddb database.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Landon Curt Noll 2004-04-20 03:01:25 EDT
This same bug shows up in RHEL3. 
 
In order to play audio CDs that I made (from my own audio test 
samples -- and this no CDDB record), I have to disable CDDB 
lookups. 
Comment 2 Landon Curt Noll 2004-04-20 03:03:27 EDT
Created attachment 99550 [details]
KDE backtrace for Xscd

This backtrace is when CDDB is enabled and a non-CDDB audio CD
is found by Kscd.
Comment 3 Ngo Than 2004-04-21 12:18:54 EDT
i don't see location where it allows you to disable!

i cannot reproduce it here. It would be nice if you could give me a
better testcase to reproduce this problem. Thanks
Comment 4 Landon Curt Noll 2004-04-21 13:01:50 EDT
Start KsCD.  Click on the "Hammer / Screwdriver" icon to 
get the CD Player Configuration window.  Click on the 
freedb icon.  Unclick the "Enable remote freedb" box. 
Click OK. 
 
Unfortunately the solution is to disable ALL CDDB looks 
to avoid crashing on a CD simply because it is too new 
to have an entry or too obscure. 
Comment 5 Orion Poplawski 2004-04-27 17:37:35 EDT
I have the same problem.  Here is the KDE Crash Handler trace (not
terribly usefull):

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1084520512 (LWP 31686)]
0x00eb5c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x00eb5c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0068eb03 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x0044e6fc in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4

Comment 6 Landon Curt Noll 2004-12-06 16:47:18 EST
I noticed that this bug was still in the NEEDINFO state, so perhaps
this information will help move things along:

0) Verify that KsCD has the freedb service enabled and configured
    0a) start KsCD without a CD
    0b) click on the hammer and screwdriver icon to get the "CD Player
        Configuration" window
    0c) click in the "freedb" icon on the left side
    0d) enable [X] "Enable remote freedb"
    0e) enable [X] "Enable auto save to local database"
    0f) use a freedb base directory (/usr/share/apps/kscd/cddc/ or
        whatever ...)
    0g) freedb server: "freedb.freedb.org http 80 /~cddb/cddb.cgi"
    0h) click OK
1) Use the freedb on a well known music CD
    1a) insert a well known music CD that you  into the CDROM drive
    1b) start playing the music CD
    1c) click on the file drawer icon to start "CD Database Editor"
    1d) click "Fetch Info" button
    1e) click OK
2) Use freedb on an obscure music
    1a) insert a music CD that has never been entered into the freedb
        NOTE: Sometimes freedb will find the wrong information by
              mistake.  This will not trigger the bug.  You need a
              very new, or obscure, or some self made music CD
              with track layout that does not match an existing
              entry in the freedb.  If freedb asks you to pick a CD
              or gives you (perhaps the wrong) track info, then you
              do not have a CD that is "unknown" to freedb.
    2) watch KsCD crash
Comment 7 Ngo Than 2004-12-07 16:29:53 EST
with your instructions, i have tried to reproduce this problem on  
FC3 with KDE 3.3.1. It works fine for me. I did not see any crash. 
 
My advice, please do update to FC3 ;-) 

Note You need to log in before you can comment on or make changes to this bug.