Bug 1189083 - [doc] please document 'skip_if_unavailable' Repo flag
Summary: [doc] please document 'skip_if_unavailable' Repo flag
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1156485
TreeView+ depends on / blocked
 
Reported: 2015-02-04 12:20 UTC by Jakub Filak
Modified: 2016-12-01 00:48 UTC (History)
7 users (show)

Fixed In Version: dnf-plugins-core-0.1.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 18:49:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jakub Filak 2015-02-04 12:20:43 UTC
Description of problem:
An uber-cool script I am porting to DNF downloads debug info rpm from all defined repositories having ID matching string "*debug*". The script is run by regular users who don't necessary have the privileges to update repository settings and don't necessary understand to concept of repositories, debuginfo packages and other computer stuff, so the script must make decisions on behalf of its users. One of the crucial features is to do its best to finish downloading successfully without any obstructions such as abortions due to unavailability of a particular repository. An unavailable repositories isn't a big issue for the script because we usually need only a fraction of downloaded packages to generate a good backtrace (we download debuginfos for all dynamically linked objects but we need only those that are currently present on stack - but we don't know them until we generate a backtrace) and also matching ID to "*debug*" sometimes leads to enabling of low quality repositories.

Please make it possible to set 'skip_if_unavailable' repository flag in DNF API.


Version-Release number of selected component (if applicable)::
dnf-0.6.3-2.fc21.noarch

Comment 1 Honza Silhan 2015-02-23 17:30:11 UTC
PR: https://github.com/rpm-software-management/dnf/pull/225

Comment 2 Jakub Filak 2015-03-05 10:50:37 UTC
I met Jan in person and we found out that Repo class already have the skip_if_unavailable flag but the flag isn't documented.

Comment 3 Fedora Update System 2015-03-31 18:17:54 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 4 Fedora Update System 2015-04-02 01:44:09 UTC
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-04-03 11:39:29 UTC
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 6 Fedora Update System 2015-04-06 18:49:20 UTC
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-04-16 09:05:13 UTC
dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21

Comment 8 Fedora Update System 2015-05-08 07:33:13 UTC
dnf-plugins-core-0.1.5-2.fc21, dnf-0.6.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.