Bug 118917 - Vim: Caught deadly signal SEGV
Summary: Vim: Caught deadly signal SEGV
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vim   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-22 19:45 UTC by Marcel Mol
Modified: 2007-04-18 17:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 14:34:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marcel Mol 2004-03-22 19:45:36 UTC
Description of problem:
Editing a simple text file with vim gives me:

 Vim: Caught deadly signal SEGV

This seems to be related to the setting of the LANG environment variable

Version-Release number of selected component (if applicable):

6.2.253-2

How reproducible:

always

Steps to Reproduce:

1. (from tcsh)

2. setenv LANG en_US.C

3. run vi

4. notice output: Vim: Caught deadly signal SEGV

5. The only way to get a prompt bakc is to kill -9 the process
   from another shell.

Additional info:

I know the LANG setting is bogus but it should not crash programs
like this.
Resetting LANG back to something like en_US.UTF-8 resolves the problem.


Note You need to log in before you can comment on or make changes to this bug.