Bug 1189221 - LVM should not default to thin_pool_autoextend_threshold = 100
Summary: LVM should not default to thin_pool_autoextend_threshold = 100
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: cluster-qe@redhat.com
Milan Navratil
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1295396 1313485 1295577
TreeView+ depends on / blocked
 
Reported: 2015-02-04 17:29 UTC by Matěj Cepl
Modified: 2016-11-04 04:08 UTC (History)
12 users (show)

Fixed In Version: lvm2-2.02.152-1.el7
Doc Type: Release Note
Doc Text:
LVM2 now displays a warning message when autoresize is not configured The thin pool default behavior is not to autoresize the thin pool when the space is going to be exhausted. Exhausting the space can have various negative consequences. When the user is not using autoresize and the thin pool becomes full, a new warning message notifies the user about possible problems so that they can take appropriate actions, such as resize the thin pool, or stop using the thin volume.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:08:24 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Matěj Cepl 2015-02-04 17:29:56 UTC
Description of problem:
Using thinp can lead to exhaustion of data which leads to bad crashes.

Version-Release number of selected component (if applicable):
kernel-3.10.0-225.el7.drmupdate4.x86_64
xfsprogs-3.2.1-5.el7.x86_64
lvm2-libs-2.02.113-1.el7.x86_64
lvm2-2.02.113-1.el7.x86_64

Comment 2 Zdenek Kabelac 2015-11-19 15:57:59 UTC
Problem resolved slightly differently.

Whenever user 'over-provisions' thin-pool space and auto extension is NOT configured, a WARNING about this state is shown during 'lvcreate' command.

As long as there is 'enough' space in thin-pool for all thin volumes, autoextension (and associated  dmeventd monitoring) is not needed.

Applies from version lvm2  2.02.124 and never.

Comment 5 Mike McCune 2016-03-28 22:58:03 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 7 Corey Marthaler 2016-06-13 20:56:48 UTC
Verified that the warning mentioned in comment #2 is present when attempting to over provision with either lvextend or lvcreate and the auto extend threshold is turned off (set to 100).

However, unlike what the subject states, the default does remain at 100.

3.10.0-419.el7.x86_64
lvm2-2.02.156-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
lvm2-libs-2.02.156-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
lvm2-cluster-2.02.156-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-1.02.126-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-libs-1.02.126-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-event-1.02.126-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-event-libs-1.02.126-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-persistent-data-0.6.2-0.1.rc8.el7    BUILT: Wed May  4 02:56:34 CDT 2016


[root@host-083 ~]# lvs -a -o +devices
  LV              VG            Attr       LSize   Pool Origin Data% Meta% Devices
  POOL            snapper_thinp twi-aot---   2.00g             0.02  1.66  POOL_tdata(0)
  [POOL_tdata]    snapper_thinp Twi-ao----   2.00g                         /dev/sdh1(1)
  [POOL_tmeta]    snapper_thinp ewi-ao----   4.00m                         /dev/sdb1(0)
  extend_snap     snapper_thinp Vwi-a-t---   1.20t POOL origin 0.00
  [lvol0_pmspare] snapper_thinp ewi-------   4.00m                         /dev/sdh1(0)
  origin          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other1          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other2          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other3          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other4          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other5          snapper_thinp Vwi-a-t---   1.00g POOL        0.01

[root@host-083 ~]# lvcreate  --virtualsize 1G -T snapper_thinp/POOL -n other6
  WARNING: Sum of all thin volume sizes (1.21 TiB) exceeds the size of thin pool snapper_thinp/POOL and the size of whole volume group (124.96 GiB)!
  For thin pool auto extension activation/thin_pool_autoextend_threshold should be below 100.
  Logical volume "other6" created.

[root@host-083 ~]# lvextend -l+1000000%FREE snapper_thinp/other1
  WARNING: Sum of all thin volume sizes (1.17 PiB) exceeds the size of thin pool snapper_thinp/POOL and the size of whole volume group (124.96 GiB)!
  For thin pool auto extension activation/thin_pool_autoextend_threshold should be below 100.
  Size of logical volume snapper_thinp/other1 changed from 1.00 GiB (256 extents) to 1.17 PiB (314760256 extents).
  Logical volume other1 successfully resized.

[root@host-083 ~]# lvs -a -o +devices
  LV              VG            Attr       LSize   Pool Origin Data% Meta% Devices
  POOL            snapper_thinp twi-aot---   2.00g             0.02  1.76  POOL_tdata(0)
  [POOL_tdata]    snapper_thinp Twi-ao----   2.00g                         /dev/sdh1(1)
  [POOL_tmeta]    snapper_thinp ewi-ao----   4.00m                         /dev/sdb1(0)
  extend_snap     snapper_thinp Vwi-a-t---   1.20t POOL origin 0.00
  [lvol0_pmspare] snapper_thinp ewi-------   4.00m                         /dev/sdh1(0)
  origin          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other1          snapper_thinp Vwi-a-t---   1.17p POOL        0.00
  other2          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other3          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other4          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other5          snapper_thinp Vwi-a-t---   1.00g POOL        0.01
  other6          snapper_thinp Vwi-a-t---   1.00g POOL        0.01

Comment 9 errata-xmlrpc 2016-11-04 04:08:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.