Bug 1189363 - ignore_deletes option is not something you can configure
Summary: ignore_deletes option is not something you can configure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1127401
Blocks: 1217929
TreeView+ depends on / blocked
 
Reported: 2015-02-05 06:10 UTC by Aravinda VK
Modified: 2016-06-16 12:41 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1127401
: 1217929 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:41:05 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-02-05 06:10:25 UTC
+++ This bug was initially created as a clone of Bug #1127401 +++

Description of problem:

When I try to set ignore-deletes on geo-replication, it tells me it is a "Reserved option".  This should not be the easy, right?

Comment 1 Anand Avati 2015-02-05 06:14:34 UTC
REVIEW: http://review.gluster.org/9583 (geo-rep: Re Enable ignore_deletes Option) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Anand Avati 2015-03-26 18:21:34 UTC
REVIEW: http://review.gluster.org/9583 (geo-rep: Re Enable ignore_deletes Option) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Anand Avati 2015-04-27 11:39:04 UTC
COMMIT: http://review.gluster.org/9583 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 5dd40bd4ad768c4d2eb07520efeb49467c709df6
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Feb 4 23:08:31 2015 +0530

    geo-rep: Re Enable ignore_deletes Option
    
    If this option is set, Deletes will not be propogated to Slave.
    This option is applicable for UNLINK and RMDIR.
    
    gluster volume geo-replication <MASTER> <SLAVEHOST>::<SLAVEVOL> \
            config ignore_deletes true
    
    Default value is false.
    
    PS: Use this option with caution, If you create the file in master
    with same path then it fails to sync to slave. Old file in Slave
    will have different GFID compared to New.
    
    BUG: 1189363
    Change-Id: I1f7816d1ea36460a654873739d3fb1b6c13e0f8d
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/9583
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>

Comment 4 Aravinda VK 2015-05-18 10:46:48 UTC
This bug is getting closed because a release has been made available that
should address the reported issue. In case the problem is still not fixed with
glusterfs-3.7.0, please open a new bug report.

Comment 5 Niels de Vos 2016-06-16 12:41:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.