Bug 1189407 - [atomic] Unable to boot if some of disk drives are iSCSI
Summary: [atomic] Unable to boot if some of disk drives are iSCSI
Status: CLOSED DUPLICATE of bug 1171298
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.1
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: dracut-maint
QA Contact: Ladislav Jozsa
Yoana Ruseva
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1147383
TreeView+ depends on / blocked
 
Reported: 2015-02-05 09:13 UTC by Ladislav Jozsa
Modified: 2015-10-22 13:27 UTC (History)
5 users (show)

(edit)
Red Hat Enterprise Linux Atomic Host 7.1.0 offers iSCSI support during Anaconda installation, but the current content set does not include iSCSI support, so the system will not be able to access the storage. Choosing this option in the installer is not recommended.
Clone Of:
(edit)
Last Closed: 2015-06-01 13:00:15 UTC


Attachments (Terms of Use)
rdsosreport.txt (1.25 MB, text/plain)
2015-02-05 09:13 UTC, Ladislav Jozsa
no flags Details

Description Ladislav Jozsa 2015-02-05 09:13:19 UTC
Created attachment 988460 [details]
rdsosreport.txt

Description of problem:
RHEL Atomic host is unable to boot when the destination hard drives are composed of local drives and iSCSI drives.

Version-Release number of selected component (if applicable):
anaconda 19.31.79-1
RHEL Atomic Host 20150129.0

How reproducible:
always

Steps to Reproduce:
1. Prepare a machine with at least one local hard drive connected to network with iSCSI targets
2. Start installation
3. Add iSCSI targets
4. Select local hard drive and at least one iSCSI target
5. Finish the installation, reboot

Actual results:
Host is unable to boot, it ends in dracut's emergency shell.

Expected results:
Host boots up

Additional info:
rdsosreport.txt attached with rd.debug turned on

Comment 2 Harald Hoyer 2015-02-05 15:33:48 UTC
Kernel command line:

BOOT_IMAGE=/ostree/rhel-atomic-host-5dfb4e57904b41f15d098be05bcc6b80feedf3961c1f916f18daffcd2e8d5058/vmlinuz-3.10.0-227.el7.x86_64 netroot=iscsi:@10.0.0.1::3260::iqn.2010-04.virt.nap:default netroot=iscsi:@10.0.0.1::3260::iqn.2010-04.virt.nap:second vconsole.keymap=us iscsi_initiator=iqn.1994-05.com.redhat:933d2fb45553 rd.lvm.lv=rah_system1/swap rd.lvm.lv=rah_system1/root crashkernel=auto vconsole.font=latarcyrheb-sun16 ifname=eth0:52:54:00:12:34:56 ip=eth0:dhcp root=/dev/mapper/rah_system1-root ostree=/ostree/boot.0/rhel-atomic-host/5dfb4e57904b41f15d098be05bcc6b80feedf3961c1f916f18daffcd2e8d5058/0 console=ttyS0 rd.debug



ifname=eth0:52:54:00:12:34:56 should never be on the kernel command line.

try "ifname=myeth0:52:54:00:12:34:56 ip=myeth0:dhcp"


Nevertheless, the initramfs of the atomic host does not seem to have iSCSI support.

Comment 3 Yoana Ruseva 2015-02-19 17:06:15 UTC
Hi Milan, 

This commit in the 7.1_BETA branch of the Release Notes contains the description from the Doc Text field:

bfdca07 Added 4 Known Issues for Atomic.

Thanks.

Comment 6 Harald Hoyer 2015-06-01 12:54:42 UTC
Colin Walters, can we reassign this bug to something else than dracut? Clearly, it is not the fault of dracut, that the atomic host has no support for iSCSI.

Comment 7 Colin Walters 2015-06-01 13:00:15 UTC

*** This bug has been marked as a duplicate of bug 1171298 ***


Note You need to log in before you can comment on or make changes to this bug.