Bug 118945 - redhat-config-packages uses "exec python" if user has python elsewhere and first on PATH it may fail
redhat-config-packages uses "exec python" if user has python elsewhere and fi...
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-22 19:18 EST by Ezequiel Panepucci
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ezequiel Panepucci 2004-03-22 19:18:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
/usr/sbin/redhat-config-packages should be sanitized.

the script /usr/sbin/redhat-config-packages is using whatever python
it finds first on the PATH instead of using the python
that comes with the system (and has therefore all python modules
that the script depends on).

In my case I have python 2.3 installed on /usr/local/ without the gtk 
module so the line:

import gtk

from the script /usr/share/redhat-config-packages/MainWindow.py

will fail because /usr/sbin/redhat-config-packages is starting the app
with

   exec python 

when it should be
   exec /usr/bin/python2

or something similar





Version-Release number of selected component (if applicable):
redhat-config-packages-1.1.8-1

How reproducible:
Always

Steps to Reproduce:
1.install python in /usr/local
2.put /usr/local/bin first on your PATH
3.try running the app
    

Actual Results:  Unable to import gtk module.  This may be due to
running without
$DISPLAY set.  Exception was:
No module named gtk
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 11, in ?
    sys.exit(0)
NameError: name 'sys' is not defined
[

Expected Results:  it should run

Additional info:
Comment 1 Jeremy Katz 2005-09-21 16:17:51 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.