Bug 118969 - Extreamly difficult to install.
Extreamly difficult to install.
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2004-03-23 08:44 EST by David Harel
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-03-23 11:28:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Harel 2004-03-23 08:44:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
Installation of KDE 3.2.1 on RH9 from:
I did a full upgrade to KDE3.2.1 using the files in the above location
including the kdevelop package.

The installation was irritating. First I did rpm -U --force --nodeps
to all the packages I wanted but since I had problems with kdevelop I
uninstalled all the KDE and QT packages and installed the new version
making sure I got no dependency problems. This was very annoying
because I had to do find the order of the packages to be installed by
trial on error but this is not the end of the story.
I had to install many packages that were not part of RH 9/Fedora like
libmusicbrainz in order to have my machine up-to-date. Also I had to
revert to older version some packages I already had like openssl and 
liblm_sensors. This is really irritating.

I think RH people should make sure they use generic base machine like
RH 9 and verify which packages should be updated and they should at
least provide links to those packages (would be even better if they
had those packages in the download directory).
Also it is very important that in the ftp directory of the packages
will be a document that explains the packages, what is the right order
to install them and what other packages should be installed. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Just try to install it on Vanila RH9

Additional info:
Comment 1 Ngo Than 2004-03-23 11:28:03 EST
You should not do that, the rpm packages were built for Fedora Core 1!

The update will not work on RHL 9.

Note You need to log in before you can comment on or make changes to this bug.