Bug 118971 - same version of gcl can't compile between redhat releases
same version of gcl can't compile between redhat releases
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-23 08:58 EST by Jonathan Hudson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 10:01:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Hudson 2004-03-23 08:58:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
gcl 2.5.3 compiled and worked fine under red hat 9.0.
Under Fedora Core 1 gcl 2.5.3 segfaults during compilation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.tar -xzvf  gcl-2.5.3.tar.gx
2.cd gcl-2.5.3
3../configure
4.make

    

Actual Results:  The make progresses for a long time
but eventually segfaults.

Expected Results:  make should finish

Additional info:
Comment 1 Jakub Jelinek 2004-03-23 09:05:26 EST
What segfaults? GCC or GCL?  If the latter, then it is more probably
a bug on GCL's side.
You might also try setarch i386 make
if GCL doesn't like address space randomization Fedora Core kernels
do.
Comment 2 Jonathan Hudson 2004-03-23 09:59:21 EST
I tried setarch i386 and gcl compiled and ran correctly. Thanks!
Comment 3 Jakub Jelinek 2004-03-23 10:01:30 EST
That means it makes incorrect assumptions about address space layout.
So it is GCL that needs to be fixed.

Note You need to log in before you can comment on or make changes to this bug.