Bug 1189853 - java-1.8.0-openjdk provides is missing java for RHEL6
Summary: java-1.8.0-openjdk provides is missing java for RHEL6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.8.0-openjdk
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: jiri vanek
QA Contact: Lukas Zachar
URL:
Whiteboard:
Depends On:
Blocks: 900676 1200567
TreeView+ depends on / blocked
 
Reported: 2015-02-05 16:03 UTC by Katerina Odabasi
Modified: 2015-07-22 07:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The java-1.8.0-openjdk package for Red Hat Enterprise Linux 6 did not provide the "java" virtual package. Consequently, when a package needed to use OpenJDK 8, it was necessary to require "java-1.8.0-openjdk" instead of commonly used "java". Now, it is sufficient to require "java" as expected.
Clone Of:
Environment:
Last Closed: 2015-07-22 07:44:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1427 normal SHIPPED_LIVE java-1.8.0-openjdk bug fix and enhancement update 2015-07-20 18:06:16 UTC
Red Hat Bugzilla 900676 None None None Never

Internal Links: 900676

Description Katerina Odabasi 2015-02-05 16:03:57 UTC
Description of problem:
With RHEL6 java-1.8.0-openjdk package doesn't contain in provides "java" (it contains only "java-1.8.0-openjdk".
This breaks compatibility with packages from EAP channel which requires "java".

Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-1.8.0.31-1.b13.el6_6

How reproducible:
always

Actual results:
# repoquery --provides --plugins java-1.8.0-openjdk
java-1.8.0-openjdk = 1:1.8.0.31-1.b13.el6_6
java-1.8.0-openjdk(x86-64) = 1:1.8.0.31-1.b13.el6_6
...

Expected results:
The package also provides "java"

Comment 3 Tim Savannah 2015-03-11 15:14:49 UTC
Indeed, 1.7.0 and prior base openjdk contained everything needed to run java, and -devel contained the devel stuff... as expected.

1.8.0 base package contains awt and an icon. This is bad.

/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.31-1.b13.el6_6.x86_64/jre/bin/policytool
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.31-1.b13.el6_6.x86_64/jre/lib/amd64/libawt_xawt.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.31-1.b13.el6_6.x86_64/jre/lib/amd64/libjawt.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.31-1.b13.el6_6.x86_64/jre/lib/amd64/libjsoundalsa.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.31-1.b13.el6_6.x86_64/jre/lib/amd64/libsplashscreen.so
/usr/share/applications/java-1.8.0-openjdk-1.8.0.31-1.b13.el6_6.x86_64-policytool.desktop
/usr/share/icons/hicolor/16x16/apps/java-1.8.0.png
/usr/share/icons/hicolor/24x24/apps/java-1.8.0.png
/usr/share/icons/hicolor/32x32/apps/java-1.8.0.png
/usr/share/icons/hicolor/48x48/apps/java-1.8.0.png

Comment 4 jiri vanek 2015-03-11 15:49:33 UTC
by base, you mean headless?
If headless contains awt then this is wrong.

Otherwise headless+jre still provides all what you need to run jva application (and devel to develop)

Not sure how your comment is related to misisng virtual provides.

Comment 6 jiri vanek 2015-04-09 12:16:50 UTC
Latest build contains virtual jre provides

Comment 8 Tim Savannah 2015-04-09 15:43:11 UTC
My mistake, I posted on wrong ticket. This issue bit us as well, glad to see it's moving forward!

Comment 11 errata-xmlrpc 2015-07-22 07:44:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1427.html


Note You need to log in before you can comment on or make changes to this bug.