Bug 1189856 - rpc.gssd fails to come up via systemd (Assertion `map->l_init_called' failed!)
rpc.gssd fails to come up via systemd (Assertion `map->l_init_called' failed!)
Status: CLOSED DUPLICATE of bug 1264556
Product: Fedora
Classification: Fedora
Component: gssproxy (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robbie Harwood
Fedora Extras Quality Assurance
:
Depends On: 1264556
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-05 11:12 EST by Steve Dickson
Modified: 2016-10-12 14:07 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-12 14:07:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2015-02-05 11:12:13 EST
Description of problem:
when rpc.gssd is started via systemd (systemctl start rpc-gssd) it
dies do the following:

rpc.gssd: Inconsistency detected by ld.so: dl-close.c: 764: _dl_close: Assertion `map->l_init_called' failed!

when it started from the command it works... go figure... 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. systemctl start rpc-gssd


Additional info:

Goggling around I found this patch that supposedly fixes the problem:
https://launchpadlibrarian.net/151536084/0006-gssapi-never-unload-mechanisms.patch

I got that patch from this Ubuntu bug report:
https://bugs.launchpad.net/ubuntu/+source/krb5/+bug/1231459
Comment 1 Jaroslav Reznik 2015-03-03 11:50:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 2 Fedora Admin XMLRPC Client 2015-09-01 17:36:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Robbie Harwood 2015-09-17 18:55:06 EDT
This should have been resolved in the 1.13 rebase... do you still see this issue?
Comment 4 Robbie Harwood 2015-09-17 18:57:25 EDT
Belay that; fc22 had krb5-1.13 at time of reporting.
Comment 5 Jan Kurik 2016-02-24 08:20:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 7 Jason Tibbitts 2016-08-18 20:30:53 EDT
Just hit this in rawhide, though it doesn't seem to be (easily) repeatable.

kernel-4.8.0-0.rc2.git2.1.fc26.x86_64
nfs-utils-1.3.4-0.fc26.x86_64
krb5-libs-1.14.3-5.fc26.x86_64


Aug 18 18:44:09 v01.math.uh.edu systemd[1]: Starting Preprocess NFS configuration...
Aug 18 18:44:09 v01.math.uh.edu systemd[1]: Starting Kernel Module supporting RPCSEC_GSS...
Aug 18 18:44:09 v01.math.uh.edu systemd[1]: Started Kernel Module supporting RPCSEC_GSS.
Aug 18 18:44:09 v01.math.uh.edu systemd[1]: Started Preprocess NFS configuration.
Aug 18 18:44:09 v01.math.uh.edu systemd[1]: Starting RPC security service for NFS client and server...
Aug 18 18:44:09 v01.math.uh.edu systemd[1]: Starting NFS Mount Daemon...
Aug 18 18:44:09 v01.math.uh.edu systemd[1]: Starting NFSv4 ID-name mapping service...
Aug 18 18:44:10 v01.math.uh.edu rpc.gssd[1008]: Inconsistency detected by ld.so: dl-close.c: 811: _dl_close: Assertion `map->l_init_called' failed!
Aug 18 18:44:10 v01.math.uh.edu systemd[1]: rpc-gssd.service: Control process exited, code=exited status=127
Aug 18 18:44:10 v01.math.uh.edu systemd[1]: Failed to start RPC security service for NFS client and server.
Aug 18 18:44:10 v01.math.uh.edu systemd[1]: rpc-gssd.service: Unit entered failed state.
Aug 18 18:44:10 v01.math.uh.edu systemd[1]: rpc-gssd.service: Failed with result 'exit-code'.
Aug 18 18:44:10 v01.math.uh.edu systemd[1]: Started NFSv4 ID-name mapping service.
Comment 8 Robbie Harwood 2016-08-19 12:28:46 EDT
Thanks.  This is a glibc issue; see the bug we depend on.
Comment 9 Zbigniew Jędrzejewski-Szmek 2016-10-12 13:47:59 EDT
Unfortunately it seems to be 100% repeatable here ;)
Comment 10 Zbigniew Jędrzejewski-Szmek 2016-10-12 13:49:25 EDT
kernel 4.8.0-0.rc4.git1.1.fc26.x86_64
nfs-utils-1.3.4-1.rc2.fc26.x86_64
krb5-libs-1.14.4-5.fc26.x86_64
glibc-2.24.90-10.fc26.x86_64
Comment 11 Robbie Harwood 2016-10-12 14:07:42 EDT
Bugzilla tinkering to make it clear what's going on here.

*** This bug has been marked as a duplicate of bug 1264556 ***

Note You need to log in before you can comment on or make changes to this bug.