Bug 118990 - Computer hangs when unmounting an LVM snapshot & quickly lvremove'ing it
Computer hangs when unmounting an LVM snapshot & quickly lvremove'ing it
Status: CLOSED DUPLICATE of bug 109497
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-23 12:30 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-03-23 12:30:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I wrote a script to make nightly backups by taking a LVM snapshot.
This usually works but, sometimes the machine gets (almost) completely
locked up. After some research, I think the problem is some kind of
race when doing a lvremove -f immediately after unmounting the snapshot.

Here is part of my script:

lvcreate -l 250 -s -n mysnap /dev/vg00/var
mount -o ro /dev/vg00/mysnap /mnt/snapshot
dump ...
umount /mnt/snapshot
lvremove -f /dev/vg00/mysnap

When locked, I can still ping the machine, and TCP handshaking seems
to work to some point, but no more (All network services time out
eventually). Also, keyboard and mouse don't respond.

Meanwhile, I inserted a 'sleep 5' between unmount and lvremove as a
workaround. I hope it will do the trick.

Our machine has 2 physical processors, with hyperthreading enabled on
both.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.22-1.2174.nptl, lvm-1.0.3-13

How reproducible:
Sometimes

Steps to Reproduce:
1. lvcreate -l num -s -n blah /dev/vg00/blah
2. mount /dev/vg00/blah /mnt/blah
3. umount /mnt/blah
4. lvremove -f /dev/vg00/blah
    

Actual Results:  The computer got locked up. I can't tell for sure if
an oops ocurred, since the console is blanked and the keyboard doesn't
respond.

Expected Results:  Well...

Additional info:

This is a 4 way machine (2 hyperthreaded Xeons)
Comment 1 Need Real Name 2004-04-14 12:21:12 EDT

*** This bug has been marked as a duplicate of 109497 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.