Bug 118995 - (FS CIFS) mount segfault while mounting smb share using cifs
(FS CIFS) mount segfault while mounting smb share using cifs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FC2Blocker FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-23 13:36 EST by Sergey Scobich
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 01:16:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergey Scobich 2004-03-23 13:36:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
I'm trying to mount smb share as root

# mount -t cifs //192.168.1.124/incoming /mnt/incoming
Segmentation fault

I've found the reason - /sbin/mount.cifs is missing.
I've forgot to install samba-client rpm.

Anyway segfault should not happen.
Note that after I installed samba-client (/sbin/mount.cifs is there)
no error appears - it is working.

Version-Release number of selected component (if applicable):
util-linux-2.12pre-3

How reproducible:
Always

Steps to Reproduce:
1.remove /sbin/mount.cifs
2.mount some smb share
3.
    

Actual Results:  Segmantation fault

Expected Results:  display that could not found mount.cifs file.

Additional info:

FC2T1 all updates,

kernel-2.6.3-2.1.253.2.1
Comment 1 Elliot Lee 2004-04-16 17:08:22 EDT
Yikes. This is a kernel issue as far as I can tell - the kernel gets a
general protection fault on my box.
Comment 2 Jeremy Katz 2004-05-06 23:57:10 EDT
Does this still happen with the test3 kernel?
Comment 3 Richard Hughes 2004-07-19 12:59:09 EDT
Problem fixed in fc2. Module fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.