Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1190025

Summary: Incremental Update apply button causes stacktrace
Product: Red Hat Satellite Reporter: Mike McCune <mmccune>
Component: Content ManagementAssignee: Justin Sherrill <jsherril>
Status: CLOSED ERRATA QA Contact: sthirugn <sthirugn>
Severity: high Docs Contact:
Priority: unspecified    
Version: NightlyCC: cwelton, jsherril, sthirugn
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/9221
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-08-12 05:23:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Mike McCune 2015-02-06 05:50:41 UTC
1) Setup a CV that filters out all 2015 errata
2) publish and promote to dev LE
3) reg content host to CV in Dev
4) Go to main Errata Page
5) select a few errata from the list that are in 2015 and not immediately installable
6) Click Apply Errata

Note error:

Processing by Katello::Api::V2::EnvironmentsController#index as JSON
  Parameters: {"full_result"=>"true", "organization_id"=>"1", "api_version"=>"v2"}
ActiveRecord::StatementInvalid: PGError: ERROR:  missing FROM-clause entry for table "katello_environments"
LINE 1: ...LECT DISTINCT COUNT(*) FROM "environments"  WHERE "katello_e...

https://paste.soc.redhat.com/4379/

Comment 3 Justin Sherrill 2015-02-06 14:13:23 UTC
Connecting redmine issue http://projects.theforeman.org/issues/9221 from this bug

Comment 5 sthirugn@redhat.com 2015-03-06 17:01:05 UTC
Verified.

Satellite-6.1.0-RHEL-6-20150303.0

Comment 6 Bryan Kearney 2015-08-11 13:29:48 UTC
This bug is slated to be released with Satellite 6.1.

Comment 7 errata-xmlrpc 2015-08-12 05:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2015:1592