Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
while installing 'gutterball' rpm, getting following warning messages
Installing : gutterball-1.0.10-1.el6.noarch 224/434
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
...
Version-Release number of selected component (if applicable):
Satellite 6.1.0 Beta Snap 1 Compose 3
How reproducible:
Steps to Reproduce:
1. Install Sat6 6.1 Beta Snap 1 Compose 3
2.
3.
Actual results:
Installing : gutterball-1.0.10-1.el6.noarch 224/434
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
Expected results:
no warning should be listed repeatedly. looks ugly
Additional info:
also present on compose3.
as a side-effect this is causing permission errors on gutterball. specifically when it tries to create its logfile. it results in a access denied error and gutterball halts.
Gutterball has no dependency on tomcat, big oversight, only functional because candlepin happens to be on the same system and thus it ends up installed eventually, but not at the point where gutterball is installing.
Simple fix, in process now, will rebuild asap.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHSA-2015:1592