Bug 1190066 - Some validation needs to be set on email field while creating docker compute resource
Summary: Some validation needs to be set on email field while creating docker compute ...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Container Management
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Adam Ruzicka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1190289
TreeView+ depends on / blocked
 
Reported: 2015-02-06 08:50 UTC by Sachin Ghai
Modified: 2019-09-25 20:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-20 14:31:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
see email field is filled with string '12333' on docker compute resource form (21.51 KB, image/png)
2015-02-06 08:50 UTC, Sachin Ghai
no flags Details
Wrong e-mail accepted (46.60 KB, image/png)
2016-06-30 11:50 UTC, Adam Ruzicka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 9270 0 None None None 2016-04-22 16:46:43 UTC

Description Sachin Ghai 2015-02-06 08:50:02 UTC
Created attachment 988771 [details]
see email field is filled with string '12333' on docker compute resource form

Description of problem:
I was trying create docker compute resource and while filling the form, realized that email field accepts any random string. we should set some validation on it like we have for User's form. There if you add any random string, UI raises validation error. Like wise we should have same validation for docker compute resource form for email.

Version-Release number of selected component (if applicable):
e):
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.41-1.el6.noarch
* candlepin-common-1.0.20-1.el6.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.41-1.el6.noarch
* candlepin-tomcat6-0.9.41-1.el6.noarch
* elasticsearch-0.90.10-7.el6.noarch
* foreman-1.7.2.3-1.el6_6sat.noarch
* foreman-compute-1.7.2.3-1.el6_6sat.noarch
* foreman-gce-1.7.2.3-1.el6_6sat.noarch
* foreman-libvirt-1.7.2.3-1.el6_6sat.noarch
* foreman-ovirt-1.7.2.3-1.el6_6sat.noarch
* foreman-postgresql-1.7.2.3-1.el6_6sat.noarch
* foreman-proxy-1.7.2.1-1.el6_6sat.noarch
* foreman-selinux-1.7.2.8-1.el6_6sat.noarch
* foreman-vmware-1.7.2.3-1.el6_6sat.noarch
* katello-2.2.0.2-1.el6_6sat.noarch
* katello-certs-tools-2.2.1-1.el6_6sat.noarch
* katello-common-2.2.0.2-1.el6_6sat.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-2.2.0.3-1.el6_6sat.noarch
* katello-installer-base-2.2.0.3-1.el6_6sat.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.39-8.el6.x86_64
* openldap-devel-2.4.39-8.el6.x86_64
* pulp-docker-plugins-0.2.1-0.2.beta.el6_6sat.noarch
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.5.0-0.7.beta.el6_6sat.noarch
* pulp-nodes-parent-2.5.0-0.7.beta.el6_6sat.noarch
* pulp-puppet-plugins-2.5.0-0.7.beta.el6sat.noarch
* pulp-puppet-tools-2.5.0-0.7.beta.el6sat.noarch
* pulp-rpm-plugins-2.5.0-0.7.beta.el6_6sat.noarch
* pulp-selinux-2.5.0-0.7.beta.el6_6sat.noarch
* pulp-server-2.5.0-0.7.beta.el6_6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.3.2-1.el6_6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.3.0-1.el6_6sat.noarch
* rubygem-hammer_cli-0.1.4.3-1.el6_6sat.noarch
* rubygem-hammer_cli_foreman-0.1.4.3-1.el6_6sat.noarch
* rubygem-hammer_cli_foreman_bootdisk-0.1.2.4-1.el6_6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3.1-1.el6_6sat.noarch
* rubygem-hammer_cli_gutterball-0.0.1.1-1.el6_6sat.noarch
* rubygem-hammer_cli_import-0.10.6-1.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.7.1-1.el6_6sat.noarch

How reproducible:
always 

Steps to Reproduce:
1. create docker compute resource
2. fill any random string in email field
3.

Actual results:
docker compute resource form accepts any random string for email field. 

Expected results:
we should have same validation for docker compute resource form for email.

Additional info:

Comment 2 Daniel Lobato Garcia 2015-02-06 21:39:46 UTC
Created redmine issue http://projects.theforeman.org/issues/9270 from this bug

Comment 3 Bryan Kearney 2015-08-25 18:33:20 UTC
Upstream bug component is Container Management

Comment 4 Daniel Lobato Garcia 2016-04-04 07:00:31 UTC
Now under review at https://github.com/theforeman/foreman-docker/pull/153

Comment 5 Bryan Kearney 2016-04-15 12:06:21 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9270 has been closed
-------------
Daniel Lobato Garcia
Applied in changeset commit:foreman-docker|977f7c5a137d6e1210d6c3e77db6f0f6763feaa9.

Comment 6 Adam Ruzicka 2016-06-30 11:50:03 UTC
Created attachment 1174523 [details]
Wrong e-mail accepted

Comment 7 Adam Ruzicka 2016-06-30 11:52:20 UTC
Failed.
Satellite 6.2 GA 18.1
tfm-rubygem-foreman_docker-2.0.1.10-2.el7sat.noarch

The validation does accept some e-mail addresses which do not conform to the RFC5322. See attachment in #6

Comment 8 Bryan Kearney 2017-03-20 14:31:21 UTC
There is an upstream bug for this. When this bug is fixed, the next version of Satellite will contain the fix. We will no longer be tracking this downstream. If you feel this bug was closed incorrectly, please feel free to re-open with additional information.


Note You need to log in before you can comment on or make changes to this bug.