Bug 11901 - configure can't find bzip2 library
configure can't find bzip2 library
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-04 15:36 EDT by afay
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-04 15:36:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description afay 2000-06-04 15:36:29 EDT
I'm trying to compile rpm-3.0.4 from source and ran into this problem 
while running configure. Since I'm using windows right now I can't give 
the exact error message but basicly the configure script couldn't find 
libbz2.a. I have libbz2.a installed in /usr/lib and I haven't run into any 
problems with this library before (although I can't remember compiling 
anything that needed it). I did try running ldconfig just to make sure 
that that wasn't the problem and it didn't help. I tried running make too 
but it failed on some bzip2 stuff which I'm assuming is related to this 
problem.

Any suggestions?
Comment 1 Jeff Johnson 2000-06-04 17:25:23 EDT
You will also need /usr/include/bzlib.h, and may need /usr/lib/libbz2.so.

The Right Thing To Do is install the bzip2-0.9.5d package.

Alternatively, after running ./autogen.sh, edit config.h by hand and turn
off bzip2 support (that should work, but I haven't tried recently).
Comment 2 afay 2000-06-04 18:26:18 EDT
Alright. Looks like it was a problem with bzip2. I was using bzip2-1.0pre8 and
after going back to bzip2-0.9.5d everything works. I checked the bzip2-1.0pre8
documentation and sure enough the calls to the bzip2 library were all renamed
which would explain my problems.

Note You need to log in before you can comment on or make changes to this bug.