Bug 119012 - fsck /initrd//dev/... is ugly
Summary: fsck /initrd//dev/... is ugly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-23 21:17 UTC by Alexandre Oliva
Modified: 2014-03-17 02:43 UTC (History)
1 user (show)

Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 21:12:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes the problem (421 bytes, patch)
2004-03-23 21:19 UTC, Alexandre Oliva
no flags Details | Diff

Description Alexandre Oliva 2004-03-23 21:17:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
The message printed by fsck while verifying root on LVM is ugly.

Version-Release number of selected component (if applicable):
initscripts-7.48-1

How reproducible:
Always

Steps to Reproduce:
1.Have root on LVM
2.Boot

Actual Results:  fsck says it's checking /initrd//dev/...

Expected Results:  The double slash is ugly, and shouldn't be there.

Additional info:

Comment 1 Alexandre Oliva 2004-03-23 21:19:17 UTC
Created attachment 98805 [details]
Patch that fixes the problem

The patch is probably overly cautious, since it's probably safe to assume that
rootdev begins with a slash, but it shouldn't hurt.

Comment 2 Bill Nottingham 2005-09-30 21:12:31 UTC
This should be fixed these days.


Note You need to log in before you can comment on or make changes to this bug.