Bug 1190183 - Docker Compute Resource - New Image: Submit button should be disabled upon click
Summary: Docker Compute Resource - New Image: Submit button should be disabled upon click
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Container Management
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1190289
TreeView+ depends on / blocked
 
Reported: 2015-02-06 15:12 UTC by Corey Welton
Modified: 2019-09-26 14:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:19:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 10199 0 None None None 2016-04-22 16:30:43 UTC

Description Corey Welton 2015-02-06 15:12:07 UTC
Description of problem:
When creating a New Image within a Docker compute resource, the submit button does not disable after initial submit.  An errant/accidental double-click ends up returning an error that the Image "has already been taken"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a docker compute resource
2.  Infrastructure > Compute Resources > $docker_cr > New Image
3.  begin filling out the form
4.  "Accidentally" click the Submit button twice.

Actual results:
Two submissions for this data are inadvertently submitted. 
User gets an error that the image "has already been taken" (because it has, with the first click) but gets no real indication that the first one was ever functional.

Expected results:
Disable the button upon submit.  I guess we could re-enable it upon failed create, so user can fix any errors that resulted (though I would think validation before submit would catch most of this).


Additional info:

Comment 2 Corey Welton 2015-02-06 16:15:49 UTC
Discovered on Satellite-6.1.0-RHEL-7-20150205.0

Comment 3 Bryan Kearney 2015-04-17 20:24:33 UTC
Created redmine issue http://projects.theforeman.org/issues/10199 from this bug

Comment 4 Daniel Lobato Garcia 2016-03-30 11:29:23 UTC
Under review in https://github.com/theforeman/foreman-docker/pull/152

Comment 5 Bryan Kearney 2016-04-01 18:15:27 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10199 has been closed
-------------
Daniel Lobato Garcia
Applied in changeset commit:foreman-docker|a02da228e4d5cf4be03d9f40ae7d0c97a1fcce45.

Comment 6 Lukas Pramuk 2016-06-21 12:39:47 UTC
VERIFIED.

@satellite-6.2.0-15.1.beta.el7sat.noarch
tfm-rubygem-foreman_docker-2.0.1.10-1.el7sat.noarch

Expected result has changed: New Image button is removed/not relevant to docker CR
Used manual reproducer:

1.  Create a docker compute resource
2.  Infrastructure > Compute Resources > $docker_cr

New Image button for docker CR is not present anymore

Comment 7 Bryan Kearney 2016-07-27 11:19:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.