Bug 1190207 - vdsClient/vdscli SSLError timeout error
Summary: vdsClient/vdscli SSLError timeout error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.1
Assignee: Simone Tiraboschi
QA Contact: movciari
URL:
Whiteboard: infra
: 1173638 (view as bug list)
Depends On: 1173638
Blocks: 1169290 1190636 1193058 1197441
TreeView+ depends on / blocked
 
Reported: 2015-02-06 16:29 UTC by rhev-integ
Modified: 2016-02-10 19:05 UTC (History)
17 users (show)

Fixed In Version: vdsm-4.16.13-1.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, 'hosted-engine' called the VDSM wrapping 'vdsClient' utility over SSL, which caused SSL timeout errors for long sync commands. Now, the 'vdscli' library is used instead of 'vdsClient', and this prevents SSL timeouts.
Clone Of: 1173638
Environment:
Last Closed: 2015-04-28 18:51:26 UTC
oVirt Team: Infra
Target Upstream Version:
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1190636 high CLOSED [hosted-engine] [iSCSI support] connectStoragePools fails with "SSLError: The read operation timed out" while adding a n... 2021-01-20 06:05:38 UTC
Red Hat Product Errata RHBA-2015:0904 normal SHIPPED_LIVE vdsm 3.5.1 - bug fix and enhancement update 2015-04-28 22:50:53 UTC
oVirt gerrit 36798 master MERGED vdsm: use vdscli instead of vdsClient for storage operations Never
oVirt gerrit 37559 ovirt-hosted-engine-setup-1.2 MERGED vdsm: use vdscli instead of vdsClient for storage operations Never
oVirt gerrit 38751 master MERGED vdscli: allow a connection with a configurable timeout Never
oVirt gerrit 38939 ovirt-3.5 MERGED call named arguments with their name Never
oVirt gerrit 38940 ovirt-3.5 MERGED vdscli: allow a connection with a configurable timeout Never

Internal Links: 1190636

Comment 2 Sandro Bonazzola 2015-02-20 11:08:13 UTC
Automated message: can you please update doctext or set it as not required?

Comment 5 Simone Tiraboschi 2015-03-12 12:33:32 UTC
If failing as for:
https://bugzilla.redhat.com/show_bug.cgi?id=1190636#c5

Comment 6 Yaniv Bronhaim 2015-03-19 13:57:42 UTC
Simone, please verify that now it works as you expect and notify us asap if not.

Comment 8 Sandro Bonazzola 2015-03-20 08:49:56 UTC
Missing th

Comment 10 Simone Tiraboschi 2015-03-20 11:52:37 UTC
It seams to work as expected.

Comment 11 Yaniv Bronhaim 2015-03-23 08:38:13 UTC
*** Bug 1173638 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2015-04-28 18:51:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0904.html


Note You need to log in before you can comment on or make changes to this bug.