Bug 1190243 - g++ internal compiler error on arm
Summary: g++ internal compiler error on arm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1191164 1191695 (view as bug list)
Depends On:
Blocks: ARMTracker F22AlphaBlocker 1167004
TreeView+ depends on / blocked
 
Reported: 2015-02-06 18:42 UTC by Thomas Moschny
Modified: 2015-02-16 14:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-12 10:49:34 UTC


Attachments (Terms of Use)
pubkey_if_algo.ii (551.49 KB, text/plain)
2015-02-07 11:19 UTC, Jakub Jelinek
no flags Details


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 65003 None None None Never

Description Thomas Moschny 2015-02-06 18:42:58 UTC
Trying to build botan-1.10.9-3.fc22 (git 4083bc6), I see an internal compiler error on armv7hl only. The package builds fine on i686 and x86_64.

...
In file included from src/pubkey/if_algo/if_algo.cpp:8:0:
build/include/botan/if_algo.h: In constructor 'Botan::IF_Scheme_PrivateKey::IF_Scheme_PrivateKey(Botan::RandomNumberGenerator&, const Botan::AlgorithmIdentifier&, const Botan::MemoryRegion<unsigned char>&)':
build/include/botan/if_algo.h:49:29: internal compiler error: Segmentation fault
       IF_Scheme_PublicKey() {}
                             ^
...


The failing build is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=8848748

Comment 1 Fedora Blocker Bugs Application 2015-02-07 09:32:42 UTC
Proposed as a Blocker for 22-alpha by Fedora user pbrobinson using the blocker tracking app because:

 Feature/Toolchain issues

Comment 2 Jakub Jelinek 2015-02-07 11:19:56 UTC
Created attachment 989165 [details]
pubkey_if_algo.ii

Preprocessed source as captured from a scratch build and uuencoded into the build.log.
Can't reproduce this with a x86_64-linux -> armv7hl-linux-gnuabi cross-compiler though, so I'm afraid I'll need access to a real Fedora 22 / armv7hl box to debug this.

Comment 3 Peter Robinson 2015-02-07 12:06:34 UTC
blc: can you let Jakub know a box where he can login to debug this? Is there devices in Beaker?

Comment 4 Dave Johansen 2015-02-07 21:07:34 UTC
Just in case this helps, ODB appears to be hit by the same problem ( https://kojipkgs.fedoraproject.org//work/tasks/645/8860645/build.log ).

Comment 5 Dan Mossor [danofsatx] 2015-02-09 17:57:07 UTC
Discussed at 02-09-2015 Blocker Review Meeting:
http://meetbot.fedoraproject.org/fedora-blocker-review/2015-02-09/fedora-blocker-review.2015-02-09-17.00.log.txt

RejectedBlocker - This bug doesn't violate any Alpha criterion.

Comment 6 Dan Mossor [danofsatx] 2015-02-09 17:59:03 UTC
Correction:

Discussed at 02-09-2015 Blocker Review Meeting:
http://meetbot.fedoraproject.org/fedora-blocker-review/2015-02-09/fedora-blocker-review.2015-02-09-17.00.log.txt

RejectedBlocker - This bug doesn't violate any of the Alpha criteria, but has the potential to affect more. If it turns out this bug manifests itself in a larger way to affect upgrades or building a TC/RC, please repropose.

Comment 7 Peter Robinson 2015-02-10 10:06:17 UTC
Still not fixed in 5.0.0-0.10.fc225.0.0-0.10.fc22

Comment 9 Jakub Jelinek 2015-02-10 15:14:51 UTC
Finally managed to reproduce.

Comment 10 Adam Williamson 2015-02-11 19:48:04 UTC
*** Bug 1191695 has been marked as a duplicate of this bug. ***

Comment 11 Peter Robinson 2015-02-12 10:49:34 UTC
So it looks like botan is fixed with 5.0.0-0.11:
http://koji.fedoraproject.org/koji/taskinfo?taskID=8906804

ODB looks good too:
http://koji.fedoraproject.org/koji/buildinfo?buildID=609655

Comment 12 Thomas Moschny 2015-02-12 11:00:16 UTC
Thanks you!

Comment 13 Vitezslav Crhonek 2015-02-16 14:54:26 UTC
*** Bug 1191164 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.