Bug 1190302 - Incorrect OIDs for SHA2 algorithms
Summary: Incorrect OIDs for SHA2 algorithms
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: jss
Version: 6.7
Hardware: other
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Christina Fu
QA Contact: Asha Akkiangady
URL:
Whiteboard:
Depends On: 1040638 1040640
Blocks: 530474 1061410
TreeView+ depends on / blocked
 
Reported: 2015-02-07 00:37 UTC by Matthew Harmsen
Modified: 2015-07-22 06:28 UTC (History)
8 users (show)

Fixed In Version: jss-4.2.6-35.el6
Doc Type: Bug Fix
Doc Text:
Previously, the HASH_ALGORITHM constant was defined incorrectly. As a consequence, object identifiers (OIDs) for SHA-256, SHA-384, and SHA-512 hash functions were incorrect. With this update, the underlying source code has been modified, and the mentioned OIDs are now correct. (BZ#1190302)
Clone Of: 1040640
Environment:
Last Closed: 2015-07-22 06:28:46 UTC


Attachments (Terms of Use)
Patch for SHA OID (772 bytes, patch)
2015-02-13 17:29 UTC, Matthew Harmsen
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1315 normal SHIPPED_LIVE jss bug fix and enhancement update 2015-07-20 17:53:25 UTC

Comment 1 Matthew Harmsen 2015-02-13 17:29:11 UTC
Created attachment 991448 [details]
Patch for SHA OID

Comment 3 Roshni 2015-04-09 16:48:42 UTC
Verified using jss-4.2.6-35.el6.x86_64 by executing the steps explained in https://bugzilla.redhat.com/show_bug.cgi?id=1040640#c5 and verifying the expected result. Reproduced the bug using jss-4.2.6-24.el6.x86_64 and compared the difference in OIDs.

Comment 5 errata-xmlrpc 2015-07-22 06:28:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1315.html


Note You need to log in before you can comment on or make changes to this bug.