Bug 1190307 - 3.18.4-200.fc21 (and later) cause guest/host CPU compatibility failures
Summary: 3.18.4-200.fc21 (and later) cause guest/host CPU compatibility failures
Keywords:
Status: CLOSED DUPLICATE of bug 1182650
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-07 02:06 UTC by Bill Nottingham
Modified: 2015-02-10 19:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-10 10:06:51 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2015-02-07 02:06:35 UTC
Description of problem:

I have a variety of virt images on my laptop. If I attempt to boot them under 3.18.4-200.fc21 and later (including the latest update 3.18.5-201.fc21), I get:

Error starting domain: unsupported configuration: guest and host CPU are not
compatible: Host CPU does not provide required features: rtm, hle

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 89, in
cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 125, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1388, in
startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 999, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: unsupported configuration: guest and host CPU are not
compatible: Host CPU does not provide required features: rtm, hle

kernel-3.18.3-201.fc21 and earlier work fine.

I assume this is because the kernel has some updated microcode (or similar) and is now correctly disabling HLE?

Version-Release number of selected component (if applicable):

kernel-3.18.4-200.fc21 and later

How reproducible:

100%

Steps to Reproduce:
1. boot system
2. attempt to start virt images

Actual results:

Fails

Expected results:

Succeeds in some reasonable way.

Additional info:

qemu-system-x86-2.1.3-1.fc21.x86_64, if it matters.

Comment 1 Ján Tomko 2015-02-10 10:06:51 UTC
The virtual machine asks for a CPU with those features, but they are not provided by the host.

Try changing the CPU manually to omit those features:
<cpu mode="custom" match="exact">
    <model fallback="forbid">Haswell</model>
    <feature policy='disable' name='rtm'/>
    <feature policy='disable' name='hle'/>
</cpu>

*** This bug has been marked as a duplicate of bug 1182650 ***

Comment 2 Josh Boyer 2015-02-10 13:51:03 UTC
As a bit more information, Intel pushed a firmware update that disabled the rtm/hle operations entirely because the TSX support in Haswell is broken in the chip.  It works... until it doesn't.  Fedora includes that microcode update and it is applied during early boot now.


Note You need to log in before you can comment on or make changes to this bug.