Bug 119032 - Applications using X core font will crash in zh_CN.UTF-8 with latest xorg-x11
Applications using X core font will crash in zh_CN.UTF-8 with latest xorg-x11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: FC2Blocker 117355
  Show dependency treegraph
 
Reported: 2004-03-23 20:01 EST by Yu Shao
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.6.6-0.2004_03_30.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 21:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yu Shao 2004-03-23 20:01:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.4.1)
Gecko/20031030

Description of problem:
Applications using X core font will crash in zh_CN.UTF-8 locale with
the latest xorg-x11. Suggeste patch is here with upstream:
http://bugs.xfree86.org/show_bug.cgi?id=991

Version-Release number of selected component (if applicable):
xorg-x11-0.0.6.6-0.0.2004_03_11.6 

How reproducible:
Always

Steps to Reproduce:
1. Using httx
2. Activate Input Method in zh_CN.UTF-8 locale
3. httx will crash and restart
    

Actual Results:  httx will crash and restart

Expected Results:  httx is running consistently

Additional info:
Comment 2 Mike A. Harris 2004-03-23 20:49:39 EST
Changing incorrect version from "2" to "devel"
Comment 3 Mike A. Harris 2004-03-23 20:55:00 EST
yshao:  I've had a look at your XFree86.org bug report above.
Since we no longer ship XFree86 in Fedora Core development, can you
file a bug report at http://bugs.freedesktop.org against the "xorg"
component for this issue, and mark it as blocking bug #213, the
release tracker.  You can cross reference the XFree86.org bug
report also if you like.

That way it'll get reviewed by the upstream we're using, and
hopefully included in CVS this week sometime.

TIA
Comment 4 Mike A. Harris 2004-03-30 03:38:37 EST
yshao)

What is the upstream bugs.freedesktop.org bug number for this
issue?

Comment 6 Mike A. Harris 2004-04-06 01:12:05 EDT
I've added the patch that went into XFree86 CVS, to the upstream bug
report on freedesktop.org above.  I've committed the patch to
our xorg-x11 package CVS, and it will be in the next build in
rawhide.  I'll close this report once the package is built.

Comment 7 Mike A. Harris 2004-04-06 21:54:40 EDT
Fixed in 0.6.6-0.2004_03_30.4 in dist-fc2.

Closing as 'RAWHIDE'

Note You need to log in before you can comment on or make changes to this bug.