Bug 1190344 - python-mutagen conflicts with RHEL6/7 base
Summary: python-mutagen conflicts with RHEL6/7 base
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-mutagen
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Moez Roy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1440898
TreeView+ depends on / blocked
 
Reported: 2015-02-07 12:28 UTC by Christopher Meng
Modified: 2018-09-03 11:22 UTC (History)
8 users (show)

Fixed In Version: python-mutagen-1.38-2.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-14 23:50:06 UTC


Attachments (Terms of Use)

Description Christopher Meng 2015-02-07 12:28:24 UTC
Hi,

I'd like to inform you that this package shouldn't be pushed to EPEL6+ as RHEL has already shipped it. You should retire it ASAP as it's not your responsibility to maintain a package conflicting with RHEL @base.

Also, the status of this package is annoying, I couldn't find python3-mutagen from repo. You should already know the upcoming Python3 as default change in Fedora 22.

Please fix above.

Comment 1 Orion Poplawski 2015-02-07 18:46:38 UTC
I'm sorry I didn't catch this earlier.  Indeed, Moez you need to retire this in EPEL6 and EPEL7 asap.

Comment 2 Moez Roy 2015-02-07 21:39:54 UTC
(In reply to Orion Poplawski from comment #1)
> I'm sorry I didn't catch this earlier.  Indeed, Moez you need to retire this
> in EPEL6 and EPEL7 asap.

Its not part of RHEL7 base.

I am retiring it from EL6 right now.

Comment 3 Orion Poplawski 2015-02-07 23:56:32 UTC
Hm, it's in Centos 7 base which usually lines up:

python-mutagen.noarch       1.20-6.el7        base

I can't find it in RHEL7 server, but it might be in RHEL7 Workstation.

Comment 4 Matěj Cepl 2017-04-10 17:25:26 UTC
(In reply to Orion Poplawski from comment #3)
> Hm, it's in Centos 7 base which usually lines up:
> 
> python-mutagen.noarch       1.20-6.el7        base
> 
> I can't find it in RHEL7 server, but it might be in RHEL7 Workstation.

Yes, but apparently not in EPEL-7 https://koji.fedoraproject.org/koji/taskinfo?taskID=18906558

Comment 5 Matěj Cepl 2017-04-10 17:28:51 UTC
Could I ask for the reintroduction of the package back to EPEL, please?

Comment 6 Michele Baldessari 2017-04-10 18:38:25 UTC
I had to remove it due to https://bugzilla.redhat.com/show_bug.cgi?id=1429677. Unless something has changed there, I am not sure I am allowed to reintroduce it.

Comment 7 Moez Roy 2017-04-11 18:03:19 UTC
(In reply to Michele Baldessari from comment #6)
> I had to remove it due to
> https://bugzilla.redhat.com/show_bug.cgi?id=1429677. Unless something has
> changed there, I am not sure I am allowed to reintroduce it.

It will also probably break rebuild of Audacity or Banshee (don't remember).

Can you please revert your change?

See also below mailing list thread:

On Mon, Apr 10, 2017 at 3:05 PM, Kevin Fenzi <kevin@scrye.com> wrote:
> On 04/10/2017 03:50 PM, Matej Cepl wrote:
>> Hi,
>>
>> with https://bugzilla.redhat.com/show_bug.cgi?id=1190344 python-mutagen
>> has been removed from EPEL. The problem is that it is Workstation-only
>> package, so we are now in the situation where we don’t have it either in
>> the RHEL underlying EPEL nor in EPEL itself.
>>
>> I need python-mutagen for picard package, which I would like to get to
>> EPEL-7 as well.
>>
>> I would like to follow
>> https://fedoraproject.org/wiki/EPEL:Packaging#Limited_Arch_Packages SOP
>> to ship the package in EPEL again.
>>
>> Any objections?
>
> Not here. I think this is the best way to handle these kinds of
> packages. We should also update the wiki that the same process for
> limited arch can be used for this case as well.
>
> kevin
>
>
>
> _______________________________________________
> epel-devel mailing list -- epel-devel@lists.fedoraproject.org
> To unsubscribe send an email to epel-devel-leave@lists.fedoraproject.org
>

Comment 8 Fedora Update System 2017-06-28 19:22:34 UTC
python-libdiscid-0.4.1-11.el7 python-mutagen-1.38-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-23126650f2

Comment 9 Fedora Update System 2017-06-30 01:20:19 UTC
python-libdiscid-0.4.1-11.el7, python-mutagen-1.38-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-23126650f2

Comment 10 Fedora Update System 2017-07-14 23:50:06 UTC
python-libdiscid-0.4.1-11.el7, python-mutagen-1.38-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.