Bug 119038 - Mouse and Keyboard suddenly stop responding while loading
Mouse and Keyboard suddenly stop responding while loading
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-03-23 23:44 EST by Christian Haag
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-29 16:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christian Haag 2004-03-23 23:44:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)

Description of problem:
When running the graphical installation, anaconda detects my hardware
and then brings up the grahpics window.  The mouse cursor responds for
about 10 seconds and then just stops.  A few seconds later, my
keyboard stops responding and the caps/scroll lock lights blink.  This
condition lasts until I reboot my computer.

I tried installing the OS in text mode, which worked fine, but when I
booted it up again, as soon as X started I had the same problem.

The mouse and keyboard are both PS/2, I have an Athalon 64 processor,
and I am using the 64-bit version of FC1.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Put in the Fedore Core 1 CD
2. Start the computer
3. Enter the graphical installation

Actual Results:  The mouse hangs after 10 seconds, the keyboard stops
responding, and my caps lock and scroll lock lights blink (not num lock)

Expected Results:  The installer should load and allow me to
configure/install FC1.
Comment 1 Mike A. Harris 2004-03-24 00:16:45 EST
Athlon 64 running a 64bit OS, is "x86_64" in bugzilla...

Changing Platform field.
Comment 2 Mike A. Harris 2004-03-24 00:19:13 EST
Please try to do a text mode install, and then we can investigate
the X problem after you've got the OS installed.  If the OS won't
install in text mode, then this is probably a kernel or other issue.

Once you have installed via text mode, run:

    redhat-config-xfree86 --reconfig

Then in runlevel 3, run "startx".  If it fails, please attach your
X server log and config file, and the /var/log/messages file as
individual uncompressed file attachments using the link below.
Comment 3 Christian Haag 2004-03-24 12:58:06 EST
I tried a few things after the installation, but was unable to get to
a command prompt.  It seemed to try and fail to load the graphical
login screen repeatedly.  When I finally got a prompt after booting
with the install CD, it didn't recognize any of the standard Linux
commands, e.g. redhat-config-xfree86, xf86conifg, startx, etc. and I
couldn't mount a root system on my Linux partition.

I thought it might just be a processor thing, so I tried installing
the i386 version of FC1.  The exact same thing happened (except it
correctly probed my monitor, unlike the x86_64 version)

So I think it might be a problem with my computer, rather than the OS.
  But RH9 installed perfectly, so I'm not sure exactly what's going on.
Comment 4 Mike A. Harris 2004-03-26 04:50:21 EST
"A few seconds later, my keyboard stops responding and the caps/scroll
 lock lights blink."

The kernel blinks the LEDs in morse code when it crashes under
certain circumstances.  This does not on the surface appear to be
an XFree86 bug IMHO.  It's either a kernel issue, or a hardware
issue.  I'll reassign this to the kernel component for their
assessment as well.

Thanks for the info.
Comment 5 David Lawrence 2004-09-29 16:14:52 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.