Bug 1190481 - Don't log everything to /var/log/messages
Summary: Don't log everything to /var/log/messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ga
: Director
Assignee: Lucas Alvares Gomes
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-08 14:24 UTC by Udi
Modified: 2015-08-05 13:50 UTC (History)
6 users (show)

Fixed In Version: openstack-ironic-2015.1.0-7.el7ost
Doc Type: Bug Fix
Doc Text:
A transient error in the Ironic/Heat systemd service file incorrectly redirected the logs. This fix corrects the Ironic/Heat service file and the logs redirect to the correct file.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Udi 2015-02-08 14:24:52 UTC
Description of problem:
During deployment of the overcloud, lots of heat-engine and ironic-api messages are logged into /var/log/messages. The log files of these services remain empty.


How reproducible:
100%


Steps to Reproduce:
1. Install and deploy according to https://wiki.test.redhat.com/RhevmQe/OpenStackTeam/TripleO/RhosWithTripleO


Actual results:
All logs from the deployment go to /var/log/messages


Expected results:
Logs should go to heat-engine.log and ironic-api.log

Comment 4 chris alfonso 2015-06-15 19:21:47 UTC
Should be in the next puddle.

Comment 7 Udi 2015-06-21 11:10:11 UTC
Tested with puddle 2015-06-17.2

The heat messages go in to the heat log files, but ironic still logs to /var/log/messages. There seem to be no log files for ironic at all (there is no directory called /var/log/ironic) which is strange because I think there used to be a while ago.

Comment 8 chris alfonso 2015-06-22 17:18:31 UTC
Rebuilt on Friday. Please retest.

Comment 10 Udi 2015-06-29 17:23:38 UTC
Verified in puddle 2015-06-26

Comment 12 errata-xmlrpc 2015-08-05 13:50:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.