Bug 119049 - Kernel panic - attempt to kill the idle task
Summary: Kernel panic - attempt to kill the idle task
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-24 12:48 UTC by Tomas Dobrovolny
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-24 19:39:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Serial console log (7.85 KB, text/plain)
2004-03-24 12:50 UTC, Tomas Dobrovolny
no flags Details
Serial console log (7.32 KB, text/plain)
2004-03-24 12:54 UTC, Tomas Dobrovolny
no flags Details
Serial console log (4.91 KB, text/plain)
2004-03-24 12:55 UTC, Tomas Dobrovolny
no flags Details

Description Tomas Dobrovolny 2004-03-24 12:48:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When I try to install Fedora Core 1 x86_64 system hangs with kernel 
panic about to killing idle task. Fedora Core 1 i386 work on the same 
machine without problems.

Hangs arise at any time of installation process but before any dialog 
(except media check dialog).

I try noapic, apic, mem=xxx boot params, text, graphic and expert 
installation mode. Result was the same everytime.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from installation CD
    

Actual Results:  Kernel panic

Additional info:

System configuration
MB: MSI Neo8-FISR (Chipset: Via K8T800, Via VT8237 South bridge; on 
board: Via VT8237 SATA - disabled in bios, Promise 20378 at SATA 
mode, Realtek 10/100/1000 NIC [8110S], Realtek ALC655 audio , Via 
6370 IEEE 1394)
CPU: AMD Athlon64 3200+
RAM: one 512MB DDRAM; 450MHz; 2.5CL
VGA: ATI Radeon 9800 Pro
Video: MSI TV@anywhere master(CX23881)
CD/DVD: Nec 2500A CD-RW,DVD-RW on second ATA chanel of VT8237A
HDD: ATA WDC400JB as boot disk on VT8237; SATA WD1200JD on Promise 
20378 SATA
Mouse: Microsoft wireless optical mouse 2.0 on USB

Comment 1 Tomas Dobrovolny 2004-03-24 12:50:45 UTC
Created attachment 98824 [details]
Serial console log

Comment 2 Tomas Dobrovolny 2004-03-24 12:54:37 UTC
Created attachment 98825 [details]
Serial console log

Comment 3 Tomas Dobrovolny 2004-03-24 12:55:21 UTC
Created attachment 98826 [details]
Serial console log

Comment 4 Sahil Verma 2004-03-29 03:37:33 UTC
Looks like bad hardware, specifically the CPU. Something in the higher
oreder bits of the registers (?), since i386 kernel works.

Comment 5 Tomas Dobrovolny 2004-03-29 13:58:56 UTC
It is look like a good idea. I try to found some AMD Athlon 64 CPU
test tools on AMD site, but I have not find any. Have you know some
CPU test tool for this CPU.

I try, for now, memtest86+ 1.1 (prebuild fd image from
www.memetest.org) and system passed all tests. (RAM and cache are OK)

I try install Windows XP (32-bit) and they also work fine.


Comment 6 Sahil Verma 2004-03-29 19:31:09 UTC
memtest may not always trigger the fault. Try XP 64-bit beta or
FreeBSD amd64.

Comment 7 kg4zmp@ardmore.net 2004-04-25 02:49:03 UTC
It's not a hardware problem.  I get the same error when trying to
install Fedora 64.  Windows XP 64 Beta installs with no problems.  I
have run the AMD CPU test software (amdcpuid.exe and cpuinfo.exe) and
it finds no errors with my AMD 64 3200+ CPU.  I think there is a bug
somewhere in the installer.

Comment 8 kg4zmp@ardmore.net 2004-04-27 02:43:05 UTC
I have now installed Windows XP 64 Beta and Mandrake 10.0 AMD64 Beta
successfully.  The issue with Fedora Core x86_64 on an MAD64 system is
not a hardware issue - it is a software issue, a bug in the installer.


Comment 9 kg4zmp@ardmore.net 2004-04-27 02:43:55 UTC
danged typos... an AMD64 system not a MAD64 system

Comment 10 Tomas Dobrovolny 2004-05-24 19:35:31 UTC
I have changed the CPU and all is OK. This was CPU bug.


Note You need to log in before you can comment on or make changes to this bug.