Bug 1190525 - Using alt+enter to fullscreen any rpgmaker XP game causes system to freeze
Summary: Using alt+enter to fullscreen any rpgmaker XP game causes system to freeze
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: marco
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-08 23:07 UTC by Timothy Arceri
Modified: 2016-02-10 10:10 UTC (History)
7 users (show)

Fixed In Version: marco-1.10.1-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-10 09:57:35 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Wine HQ 38064 0 None None None Never
Wine Staging 67 0 None None None Never

Description Timothy Arceri 2015-02-08 23:07:04 UTC
Full screen used to work fine under Fedora 21 until Wine was updated a month or so ago now everything is frozen when I try to go full screen (and it doesn't fullscreen properly just part of the window is redrawn in the top left) also it wont allow me to switch back.
I also see a notification pop up I think from SELinux but cant check to see what its saying. 

In the end I just have to power off my laptop.

Comment 1 Timothy Arceri 2015-02-08 23:11:13 UTC
Example app: http://www.itsqueeze.com/wp-content/uploads/2015/02/Custom_Mouse_System.tar.gz

Just run Game.exe and press alt+enter

Comment 2 Michael Cronenworth 2015-02-09 00:16:21 UTC
I can't run your app: "RGSS-RTP Standard not found."

Please file upstream.

https://bugs.winehq.org/

They will want you to perform regression testing since you noted an earlier version works.

http://wiki.winehq.org/RegressionTesting

Comment 3 Michael Cronenworth 2015-02-09 00:17:16 UTC
Sorry, not that upstream. This upstream: https://github.com/wine-compholio/wine-staging/issues

Comment 4 Timothy Arceri 2015-02-09 02:12:23 UTC
Whoops sorry about that you also need the run time package for Rpgmaker XP 

http://www.rpgmakerweb.com/download/additional/run-time-packages

Comment 5 Michael Cronenworth 2015-02-09 03:38:44 UTC
I still can't run it. "Script 'Win32 Wrapper' line 330: NoMethodError occurred."

Please post the upstream bug link when you have created it.

Comment 6 Timothy Arceri 2015-02-09 07:50:00 UTC
Please download and try the example app again I forgot to remove a script that's not needed.

Comment 7 Timothy Arceri 2015-02-10 12:51:24 UTC
I managed to get the SELinux trouble shoot detail from the issue.

SELinux is preventing /usr/bin/systemctl from using the sys_resource capability.

*****  Plugin sys_resource (91.4 confidence) suggests   **********************

If you do not want processes to require capabilities to use up all the system resources on your system;
Then you need to diagnose why your system is running out of system resources and fix the problem.  

According to /usr/include/linux/capability.h, sys_resource is required to:

/* Override resource limits. Set resource limits. */
/* Override quota limits. */
/* Override reserved space on ext2 filesystem */
/* Modify data journaling mode on ext3 filesystem (uses journaling
   resources) */
/* NOTE: ext2 honors fsuid when checking for resource overrides, so
   you can override using fsuid too */
/* Override size restrictions on IPC message queues */
/* Allow more than 64hz interrupts from the real-time clock */
/* Override max number of consoles on console allocation */
/* Override max number of keymaps */
/* Override resource limits. Set resource limits. */
/* Override quota limits. */
/* Override reserved space on ext2 filesystem */
/* Modify data journaling mode on ext3 filesystem (uses journaling
   resources) */
/* NOTE: ext2 honors fsuid when checking for resource overrides, so
   you can override using fsuid too */
/* Override size restrictions on IPC message queues */
/* Allow more than 64hz interrupts from the real-time clock */
/* Override max number of consoles on console allocation */
/* Override max number of keymaps */
/* Override resource limits. Set resource limits. */
/* Override quota limits. */
/* Override reserved space on ext2 filesystem */
/* Modify data journaling mode on ext3 filesystem (uses journaling
   resources) */
/* NOTE: ext2 honors fsuid when checking for resource overrides, so
   you can override using fsuid too */
/* Override size restrictions on IPC message queues */
/* Allow more than 64hz interrupts from the real-time clock */
/* Override max number of consoles on console allocation */
/* Override max number of keymaps */

Do
fix the cause of the SYS_RESOURCE on your system.

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that systemctl should have the sys_resource capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep shutdown /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:apmd_t:s0
Target Context                system_u:system_r:apmd_t:s0
Target Objects                Unknown [ capability ]
Source                        shutdown
Source Path                   /usr/bin/systemctl
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 3.18.5-201.fc21.x86_64
                              #1 SMP Mon Feb 2 21:00:58 UTC 2015 x86_64 x86_64
Alert Count                   8
First Seen                    2015-02-10 16:29:56 AEDT
Last Seen                     2015-02-10 23:35:12 AEDT
Local ID                      db55916b-46a2-48ab-ae7d-ab97874a181b

Raw Audit Messages
type=AVC msg=audit(1423571712.831:708): avc:  denied  { sys_resource } for  pid=7340 comm="shutdown" capability=24  scontext=system_u:system_r:apmd_t:s0 tcontext=system_u:system_r:apmd_t:s0 tclass=capability permissive=0


type=SYSCALL msg=audit(1423571712.831:708): arch=x86_64 syscall=setrlimit success=no exit=EPERM a0=7 a1=7fff9c275790 a2=0 a3=a382d4654552e42 items=0 ppid=7315 pid=7340 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=shutdown exe=/usr/bin/systemctl subj=system_u:system_r:apmd_t:s0 key=(null)

Hash: shutdown,apmd_t,apmd_t,capability,sys_resource

Comment 8 Michael Cronenworth 2015-02-10 15:26:43 UTC
That alert has nothing to do with wine.

Comment 9 Timothy Arceri 2015-03-09 06:45:25 UTC
Changing component to Marco. Most of the problems are fixed by this patch: https://github.com/mate-desktop/marco/pull/167

More information is in the upstream wine bug report.

Comment 10 Wolfgang Ulbrich 2015-03-09 09:07:45 UTC
(In reply to Timothy Arceri from comment #9)
> Changing component to Marco. Most of the problems are fixed by this patch:
> https://github.com/mate-desktop/marco/pull/167
> 
> More information is in the upstream wine bug report.

A link to upstream report is helpful.

Comment 11 Timothy Arceri 2015-03-09 09:30:27 UTC
The initial bug report was about fixing something slightly different, but it solves this bug too.

https://github.com/mate-desktop/marco/issues/166

Comment 12 Wolfgang Ulbrich 2015-03-09 09:40:00 UTC
(In reply to Timothy Arceri from comment #11)
> The initial bug report was about fixing something slightly different, but it
> solves this bug too.
> 
> https://github.com/mate-desktop/marco/issues/166

I meant the wine report, but i found it for myself :/

Comment 13 Timothy Arceri 2015-03-09 09:45:31 UTC
It's up the top under External Trackers :)

Comment 14 Wolfgang Ulbrich 2015-03-11 16:46:26 UTC
Here is a scratch build for testing.
http://koji.fedoraproject.org/koji/taskinfo?taskID=9205213
But i need to test this build a while locally.
Sorry, i can't push this build to fedora repos yet, with a patch which isn't reviewed by upstream.

Comment 15 Wolfgang Ulbrich 2015-03-18 18:06:49 UTC
Did the scratch build helps?

Comment 16 Timothy Arceri 2015-03-18 21:21:27 UTC
Hi sorry,

I previously created my own RPM with the patch applied and yes it fixed the issue. I can try your build too, but I guess the real issue is getting upstream to review it.

I've just added the info about this bug to the upstream issue tracker as it was about fixing a different but related bug, hopefully the kickstarts the conversation again.

Comment 17 Fedora Update System 2015-07-31 15:42:50 UTC
marco-1.10.1-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/marco-1.10.1-2.fc21

Comment 18 Fedora Update System 2015-08-01 02:27:08 UTC
Package marco-1.10.1-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing marco-1.10.1-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12562/marco-1.10.1-2.fc21
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2015-08-10 09:57:35 UTC
marco-1.10.1-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.