Bug 1190545 - zsh completion not installed properly
Summary: zsh completion not installed properly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: task   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Federico Hernandez
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-09 03:39 UTC by Ben Boeckel
Modified: 2015-03-05 12:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 17:20:01 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Boeckel 2015-02-09 03:39:23 UTC
Description of problem:
The zsh completion is installed to the wrong place:

    /usr/share/doc/task/scripts/zsh/_task

when it should go to:

    /usr/share/zsh/site-functions

While fixing this, the bash completion files should go to:

    /usr/share/bash-completion/completions

as well (but at least they work where they are).

Version-Release number of selected component (if applicable):
task-2.3.0-2.fc22.x86_64

Comment 1 Fedora Update System 2015-02-09 18:48:04 UTC
task-2.3.0-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/task-2.3.0-3.fc21

Comment 2 Fedora Update System 2015-02-09 18:49:04 UTC
task-2.3.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/task-2.3.0-3.fc20

Comment 3 lnie 2015-02-10 03:21:22 UTC
task-2.3.0-3.fc21 works

Comment 4 Ben Boeckel 2015-02-11 06:05:36 UTC
Rawhide is also fine. Thanks!

Comment 5 Fedora Update System 2015-02-17 02:08:24 UTC
task-2.4.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/task-2.4.1-1.fc21

Comment 6 Fedora Update System 2015-02-17 02:08:37 UTC
task-2.4.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/task-2.4.1-1.fc20

Comment 7 Ben Boeckel 2015-02-23 17:02:20 UTC
Looks like bash completion is in the wrong directory:

/usr/share/bash-completions/completions/task

when it should be:

/usr/share/bash-completion/completions/task

(note the 's' in 'bash-completions' is not supposed to be there).

Comment 8 Fedora Update System 2015-02-23 21:16:14 UTC
task-2.4.1-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/task-2.4.1-2.fc21

Comment 9 Fedora Update System 2015-02-23 21:16:25 UTC
task-2.4.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/task-2.4.1-2.fc20

Comment 10 Fedora Update System 2015-03-05 12:36:56 UTC
task-2.4.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-03-05 12:37:42 UTC
task-2.4.1-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.